Results 1 to 6 of 6

Thread: Simple question

  1. #1

    Simple question

    For winterizing, is blipping the throttle a couple times sufficient to remove water from the exhaust? I dont have an air compressor.


  2. #2
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    It all depends where you live. You might have to do other things to it to keeo the water from freezing

  3. #3
    Quote Originally Posted by ultramaxracing05 View Post
    It all depends where you live. You might have to do other things to it to keeo the water from freezing
    Ohio, we get deep freezes....so blipping the throttle doesn't clear all three water

  4. #4
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by ryanr623 View Post
    Ohio, we get deep freezes....so blipping the throttle doesn't clear all three water
    I would personally remove the hose that comes off of the pump shoe and blow the water out.... I would then fill the hose with RV waterline antifreeze. It is non toxic and pink in color. Blow it through the exhaust manifold and you should be good.

  5. #5
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,182
    +1
    98
    Don't you have a flushing fitting to the right of the pump on the shoe?

    I just connect a 3' piece of hose to it with a garden hose fitting on the end, pour in about 1/2 gallon of pink antifreeze.

    Start it up, keep the hose on and the end above the engine height. Blip the throttle a few times. If no pink stuff comes out the exhaust, add about 1/4 gallon and restart and blip again.

    This will put antifreeze through the intercooler and exhaust, and your done.
    I am in Ontario, colder than Ohio and never had an issue doing it that way.

  6. #6
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by SplishSplash View Post
    Don't you have a flushing fitting to the right of the pump on the shoe?

    I just connect a 3' piece of hose to it with a garden hose fitting on the end, pour in about 1/2 gallon of pink antifreeze.

    Start it up, keep the hose on and the end above the engine height. Blip the throttle a few times. If no pink stuff comes out the exhaust, add about 1/4 gallon and restart and blip again.

    This will put antifreeze through the intercooler and exhaust, and your done.
    I am in Ontario, colder than Ohio and never had an issue doing it that way.
    +1 use an old piece of hose attached to the stock flush port. Place a funnel in the end of the hose. Crank the ski and keep dumping in antifreeze until it comes out all of your water exits. Im open loop as well and this is what I do

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Probably a simple question
    By skraggy in forum Open Discussion
    Replies: 1
    Last Post: 12-05-2007, 06:48 PM
  2. New guy checking in,.....simple question / opinion
    By travelboysteve in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 06-19-2007, 03:06 PM
  3. Simple questions about a Raider
    By romack991 in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 01-27-2007, 03:59 PM
  4. Simple question...
    By sbogi in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 09-21-2006, 10:44 AM
  5. Simple Question.
    By Chrisrokc in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-24-2006, 11:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •