Results 1 to 4 of 4
  1. #1

    Unhappy 91 sp clicking in the electricial box..

    went to start it yesterday. and it kicked over but the battery died. so took it out taday & charged the battery. put it back in & now we have clicking noises in the electricial box. what ya think battery s dead.. the charger said full charge.. hmmmm.


  2. #2

    Join Date
    Jan 2006
    Location
    Patterson La
    Posts
    369
    +1
    54
    Your battery is bad, or your starter is bad.

  3. #3
    Sounds Like a starter solenoid is bad.

  4. #4
    TEAM BRONX TECH FAT BOY's Avatar
    Join Date
    Mar 2009
    Location
    Bronx, NY
    Posts
    353
    Open the electric box and put a rubber handle screw driver over the two posts on the selinoid and jump it. It doesn't hurt! If the starter turns, the selinoid is bad. If not, it's the starter.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. what do you use to store stuff in the glove box?
    By liquid chicken in forum Open Discussion
    Replies: 10
    Last Post: 10-14-2013, 11:48 AM
  2. Fx 160 Yamaha Cover New In The Box
    By Raider Kevin in forum Yamaha Classifieds
    Replies: 4
    Last Post: 08-28-2013, 11:11 AM
  3. Did the 00' 1200 slx need the jumper wire in the e. box?
    By 1FASTXC in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-22-2009, 05:20 AM
  4. WD40 in the electrical box...good or bad
    By paramuir in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-19-2008, 03:38 AM
  5. How does water get in the VTS box?
    By Shibby1485 in forum 4-Tec Performance
    Replies: 4
    Last Post: 11-18-2006, 01:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •