Results 1 to 4 of 4
  1. #1

    Join Date
    Sep 2011
    Location
    Lynden wa
    Posts
    10

    1995 slx 780 needs your help.

    Ok so my ski has a major intermitted missfire. It runs rough 75% of the time and perfect 25% of the time. Here is what I've done. Rebuilt carbs = no change. New plugs= no change. compression is 130 on all 3 cylinders. It has spark on all 3 plugs. I tried visual test of plugs, light tester, and started it one cylinder at a time. It will start and run with one cylinder, doesn't matter which one. I dissabled limp mode= no change.

    So I just tested the resistance in the stator.

    Alternator s/b .6 it showed .8
    Trigger s/b 220 it showed 199
    Pulse s/b 90 it showed 65
    Exciter s/b 490 it showed 422

    I don't really know anything about stators, or ohms. Is this enough off to cause my problem? Is weak spark common in these skis? Why would it be intermitted? I'm very frustrated with this thing. Please help me.


  2. #2
    john zigler's Avatar
    Join Date
    Aug 2006
    Location
    WI
    Posts
    2,545
    +1
    33
    keep things simple at first....

    change the fuel select valve ( i have new on hand)
    check the gas cap, and filler neck
    clean the fuel filter water seperator
    take the plug boots off, and cut the wires back a 1/4 + inch

    then try again.

    if all else fails, it may be a stator, or other electrical problem

  3. #3

    Join Date
    Sep 2011
    Location
    Lynden wa
    Posts
    10
    Ok, cleaned the seperator. I cut the plug wires back. I checked the resistance from the plug cap to the black/white wire on the coil. All 3 wires were within the 8k to 9k ohm range. I inspected the check valves, they seem to be in working order. I blew pressure in one check valve to see if the tank would hold pressure and it did. Then I blew more pressure to see if the release check valve was working and it did release excess pressure. Fuel is definately not the issue. It ran great for a few minutes, then the missfire started again.

    Is there any way to test the cdi? Or does anyone know if the ohm reading on my stator is way to far off?

  4. #4
    john zigler's Avatar
    Join Date
    Aug 2006
    Location
    WI
    Posts
    2,545
    +1
    33
    sounds like your stator ( magnito) is heat soaking then....

    they can be very difficult to test.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1995 slx 780 stator needed.
    By kirtzen in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-18-2012, 05:34 PM
  2. 95 Polaris SLX 780 Needs HELP!!!!
    By polarisslx780 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-28-2010, 06:33 PM
  3. RQ. I need your help over at petes again.
    By ccassone in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 06-08-2006, 10:20 PM
  4. Paging 96XPSS. I need your help over at snkypete's!
    By ccassone in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-25-2006, 06:42 PM
  5. OK Pine box derby experts - I need your help
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 11-16-2005, 04:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •