Results 1 to 10 of 10
  1. #1
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3

    EFI controller question

    Okay, I've used 2 different efi controllers on my ski and I am still running into the same problem. My accelerator light stays on while idling, does that mean its dumping fuel into my ski while I am idling (my guess is yes, but just want to verify)? I talked to Bubba (guy from riva) and he told me the settings to run, but I am still having the same problem. At first I thought it was a faulty unit, thats why I got a second one. But still running into the same problem with the second one.
    I have adjusted my idle screw and the other screw next to it. Whats the other screw do? And why the hell does the accelerator light stay on while I idle. If my ski idles above 1700, the light stays off, but if it drops below that, the light comes on. My idle is set at 1350/1400. Should it be higher?
    I am confused on this one.
    SHOOTER


  2. #2

    Join Date
    Nov 2005
    Location
    All over
    Posts
    716
    What are the setting you're using?

  3. #3
    MR. SCOVILLE UNIT SUCKMYWAKE's Avatar
    Join Date
    Aug 2005
    Location
    ASTON, PENNSYLVANIA
    Posts
    2,836
    +1
    8
    what color light is it? i think it's supposed to be on until it crosses over to the midrange settings

  4. #4
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    the yellow one is on while idling. It won't come on till the rpms drop below 1700. Whats the idle suppose to be at on these skis?
    I've tried all settings on my ski, still does the same thing.
    SHOOTER

  5. #5
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    My boat idles around 1500, and no my 2nd light doesnt come on.

    Maybe your TPS is adjusted a little high ?

    Did you and Mikey check it ?

  6. #6
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    Hey man, I waited for you to call back, guess them hills don't get good connection. The tps is the black box alongside the throttle bodies correct? If so, no. But we did mess with the two screws on the top between the first and second throttle body. I know one is the idle speed adjuster, but whats the other one?
    SHOOTER

  7. #7

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374
    I checked the tps when we had the cable and it was right on .8 if I remember right
    Mike

  8. #8
    steach's Avatar
    Join Date
    Dec 2005
    Location
    Rock Tavern, NY
    Posts
    3,174
    +1
    174
    Quote Originally Posted by shooter98xpl View Post
    My accelerator light stays on while idling, does that mean its dumping fuel into my ski while I am idling (my guess is yes, but just want to verify)? SHOOTER
    Shooter, the R&D instructions says "it is normal for the yellow light to be on along with the green light during low speed cruising even though the yellow pot setting or selection may be closed or shut off"

    #4 green
    Attached Files Attached Files

  9. #9
    MR. SCOVILLE UNIT SUCKMYWAKE's Avatar
    Join Date
    Aug 2005
    Location
    ASTON, PENNSYLVANIA
    Posts
    2,836
    +1
    8
    thats exactly what i thought

  10. #10
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    Mikey, I bet we need to check the jetworks mod, hahahaha.
    SHOOTER

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva efi controler question
    By DR2006RXP in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 02-22-2016, 09:54 PM
  2. RIVA EFI controller question
    By alex29573 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-27-2011, 02:45 PM
  3. EFI control question
    By waterkneival in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 03-22-2006, 12:00 AM
  4. EFI CONTROLLER INSTRUCTIONS (USAGE, NOT INSTALLATION)
    By ABBOTT in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 01-13-2006, 08:54 PM
  5. EFI CONTROLER & FUEL INJECTION SYSTEM FOR SALE
    By ABBOTT in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 09-06-2005, 05:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •