Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34
  1. #1
    ecpChris's Avatar
    Join Date
    Jul 2007
    Location
    ocean county nj
    Posts
    2,912
    +1
    427

    Is s3 driveshaft interchangeable with previous year RXT shafts?

    I was wondering if anyone can confirm if previous year RXT driveshafts are compatible with newer s3 Doos? I haven't had the chance to compare the two and was hoping someone knew instead of me having to pull it. I read that someone made it work at Mudbug.. Would be good to know with all of the issues
    thanks


  2. #2
    Gomer Pyle starter99's Avatar
    Join Date
    Sep 2009
    Location
    GA
    Posts
    642
    +1
    54
    i was the one at mudbug thats got and IS we put and 06 in it seem to be ok it was a bitch getting the old one out. i need to run the ski a little more i will update u. pvt MS RXP he put it in he might can put his 2 cents in also.

  3. #3
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by starter99 View Post
    i was the one at mudbug thats got and IS we put and 06 in it seem to be ok it was a bitch getting the old one out. am need to run the ski a little more i update u
    It was the old style 06 and up shaft. Gone is the nut, and back to the floating ring and c-clip. They need to send you an different bearing setup as the PTO housings are different. It wasn't an 06 shaft per-say, rather an 06 spec shaft NIB. They sent all new parts. SO MUCH easier to get off and on with the old setup. It was a time getting it off. The problem they found with the IS driveshaft was 2 things. 1. Too much play in splines that engage the impeller. 2. Improper material in order to save money. Overall, it was a better fit personally. It hasn't sunk yet has it Murray?

  4. #4
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    You ran 2 tanks through it after it was changed. No issues thus far though... Right?

  5. #5
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    Quote Originally Posted by MSRXP View Post
    It was the old style 06 and up shaft. Gone is the nut, and back to the floating ring and c-clip. They need to send you an different bearing setup as the PTO housings are different. It wasn't an 06 shaft per-say, rather an 06 spec shaft NIB. They sent all new parts. SO MUCH easier to get off and on with the old setup. It was a time getting it off. The problem they found with the IS driveshaft was 2 things. 1. Too much play in splines that engage the impeller. 2. Improper material in order to save money. Overall, it was a better fit personally. It hasn't sunk yet has it Murray?
    This is the one that went 82.1mph?

  6. #6
    Gomer Pyle starter99's Avatar
    Join Date
    Sep 2009
    Location
    GA
    Posts
    642
    +1
    54
    I have no clue yet ski was running good when me a troy was racing top end then when i headed back to JERRY parents would'nt go over 65 don't think it's a driveshaft issues tho. just got s/c pipe powder coated today going to put it on tonight . and test sometimes tom .another thing i found was to much oil in the ski maybe thats got something to do with it.

  7. #7
    Gomer Pyle starter99's Avatar
    Join Date
    Sep 2009
    Location
    GA
    Posts
    642
    +1
    54
    SCOTT if u would have showed up to mudbug u know how fast everone was running . no show scott . hope u can make it next year i got something in the works for u. coming soon in 2012

  8. #8
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by Scott View Post
    This is the one that went 82.1mph?
    Not telling?

    Yes! it is...

  9. #9
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by starter99 View Post
    I have no clue yet ski was running good when me a troy was racing top end then when i headed back to JERRY parents would'nt go over 65 don't think it's a driveshaft issues tho. just got s/c pipe powder coated today going to put it on tonight . and test sometimes tom .another thing i found was to much oil in the ski maybe thats got something to do with it.
    That could definitely have something to do with it. Troy's ski run's 81 and you were pulling on him a little. That big bitch is FAST!

    Did you get the new pipe you learned about at JSJ's shop? What about the IC piping?

    The low speed isn't the driveshaft. You know your charger is now in spec thanks to the Human Torque Wrench It really makes a difference when done right.... No question...

  10. #10
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    Quote Originally Posted by starter99 View Post
    SCOTT if u would have showed up to mudbug u know how fast everone was running . no show scott . hope u can make it next year i got something in the works for u. coming soon in 2012
    I'll make it down there at some point. Come to NJ and drive my ski there and back!

    What plans do you have for 2012 and its for me?? I'm excited

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 93 Sl 750 Jet pump, interchangeable with what years?
    By jperkinstrades in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-13-2013, 06:11 AM
  2. Some issues with my 2009 RXT 255 iS
    By WaveKing in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-08-2010, 10:56 PM
  3. Driveshaft issue with 05 RXT
    By wickedpony2007 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-26-2010, 09:16 PM
  4. 2009 rxt is 255 driveshaft help
    By starter99 in forum 4-Tec Performance
    Replies: 13
    Last Post: 09-03-2009, 11:42 AM
  5. Is a 04/05RXP ECU interchangable with a 03 SC GTX ECU?
    By gwaddle in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-30-2007, 04:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •