Results 1 to 9 of 9
  1. #1
    jeteffect's Avatar
    Join Date
    Feb 2011
    Location
    Canada
    Posts
    374
    +1
    11

    2011 GTI 155 Limited - green satellite on cluster

    Hey everyone. When should the green satellite light be lit - when the GPS is active and getting a signal, or when it can't find a GPS signal?

    Thank you.


  2. #2
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by jeteffect View Post
    Hey everyone. When should the green satellite light be lit - when the GPS is active and getting a signal, or when it can't find a GPS signal?

    Thank you.
    It should be on when there is a GPS signal. It should be on from the time the ski is on. Are you in a heavily wooded area? If you are, it still should work. Is your speed dropping in and out on the heads up display.

  3. #3
    jeteffect's Avatar
    Join Date
    Feb 2011
    Location
    Canada
    Posts
    374
    +1
    11
    Quote Originally Posted by MSRXP View Post
    It should be on when there is a GPS signal. It should be on from the time the ski is on. Are you in a heavily wooded area? If you are, it still should work. Is your speed dropping in and out on the heads up display.

    Thanks for your reply! Well, something is up.

    I can't recall the GPS light every lighting up in fact, haha. My speed is consistent and I never see it drop at all. Also my compass is working fine, no issues and I've never seen it drop or cut out at all.


    I haven't checked the fuse yet, but I'm guessing if the fuse was blown the speedo and compass won't work at all?

    Thoughts and suggestions would be appreciated.
    Thank you!

  4. #4
    jeteffect's Avatar
    Join Date
    Feb 2011
    Location
    Canada
    Posts
    374
    +1
    11
    Quote Originally Posted by MSRXP View Post
    It should be on when there is a GPS signal. It should be on from the time the ski is on. Are you in a heavily wooded area? If you are, it still should work. Is your speed dropping in and out on the heads up display.

    Is this only for GTX and Is skis?

    Thanks.

  5. #5
    jeteffect's Avatar
    Join Date
    Feb 2011
    Location
    Canada
    Posts
    374
    +1
    11
    According to my local Dealer, and after them showing my other GTI and GTS skis, it seems their clusters do not have the GPS 'light'. Basically, all is well with my ski and the GTI and GTS skis don't have a GPS light indicator and if the compass and speedo is working then there is nothing wrong with the ski or cluster.

    The GPS indication 'light' is used on the GTX skis.

    Cheers.

  6. #6
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by jeteffect View Post
    Is this only for GTX and Is skis?

    Thanks.
    Don't you have a GTX?

  7. #7
    jeteffect's Avatar
    Join Date
    Feb 2011
    Location
    Canada
    Posts
    374
    +1
    11
    Quote Originally Posted by MSRXP View Post
    Don't you have a GTX?

    No, I have a GTI 155 Limited (2011).

    Thanks.

  8. #8
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by jeteffect View Post
    No, I have a GTI 155 Limited (2011).

    Thanks.
    What a putz.... I can't read. Sorry...

  9. #9
    jeteffect's Avatar
    Join Date
    Feb 2011
    Location
    Canada
    Posts
    374
    +1
    11
    Aha, no worries. I am just glad my ski is working as expected, no issues with the cluster

    Thanks again!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 GTI 155 SE Sea Doo
    By Yellowfin13x in forum 4-Tec Performance
    Replies: 2
    Last Post: 02-21-2012, 06:52 PM
  2. 2011 GTI 155 Limited 50 Hour Service
    By jeteffect in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-19-2011, 04:06 AM
  3. New First Time Owner - 2011 GTI 155 Limited
    By jeteffect in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-11-2011, 10:15 AM
  4. Replies: 7
    Last Post: 08-03-2011, 01:34 PM
  5. 2011 GTI 155 vs RXT-X 260 iS?
    By DigitalCSI in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-13-2011, 10:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •