Results 1 to 3 of 3
  1. #1

    Join Date
    Sep 2010
    Location
    Columbia South Carolina
    Posts
    8
    +1
    1

    Smile 98 Yamaha xl1200 no display

    I bought this ski last year with new motor but the display has never worked since I purchased it. The previous owner had all the work done in Jacksonville FLA by authorized dealer he purchased the ski from . He spent around 3500 for the work so he was very surprised when I came back from test ride to say the display was out. I have replaced the display twice. None of them worked. So it leads me to believe there is another problem more than the display. I was told in the CDI box in the engine bay has a circuit board in the box that goes bad. That would be great but does anyone know where to find one is my next question if this is where everyone says to check. The ski runs great and I put a primer kit and oil pump block off on the motor to keep from burning it up. I premix. The ski rides great and everything else on the ski works like it should. I rode today and it performed wonderfully. I have 3 other skis and my current project is a 89 kawasaki 650sx stand up that needs a carb and has been hard to find as well at the right price. I want a 38mm rather than rebuild the 28mm with external fuel pump. Just a pain. If anyone can help or give me a suggestion I am all ears.


  2. #2

    Join Date
    Nov 2009
    Location
    NC
    Posts
    783
    +1
    29
    factory service manual should show you how to power up dash as if it were out of ski. Try that to determine if prob with dash or elsewhere in ski.

  3. #3

    Join Date
    Sep 2010
    Location
    Columbia South Carolina
    Posts
    8
    +1
    1
    I sold it at the start of this summer and purchased two older skis with only 30 hours on them. These old skis run great. I had to rebuild the carb on one of them. But thanks for the help. I found a jet ski club here locally and the guys are wonderful. Fun to be around and hang out with. They got me into my first 4 stroke ski we are working on now. My mechanic's wife just had a baby so he is going to tear down the motor this weekend and tell me what I need. I found a complete motor in Canada but I am hoping it is just a burnt piston and a minor repair. Have to wait and see. But thanks for the reply a while back. Sorry for not replying.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bartlett Lake Az MisHap!!!!!!98 Yamaha xl1200......
    By DanielDucati in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-01-2014, 04:34 PM
  2. Should I Run 30:1 Or 40:1 Premix Ratio In My 98'Yamaha XL1200
    By DanielDucati in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-09-2013, 08:58 PM
  3. So.......I Bought A 98' Yamaha XL1200 On Friday.....And On Saturday It Took A Shit!!
    By DanielDucati in forum Yamaha PWC Performance (2-stroke)
    Replies: 31
    Last Post: 04-18-2013, 01:07 PM
  4. 98 Yamaha XL1200
    By mmrg120 in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 08-30-2008, 09:13 PM
  5. 98 Yamaha XL1200
    By Nookie in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 07-31-2007, 08:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •