Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1
    thompsdw's Avatar
    Join Date
    Sep 2007
    Location
    Richmond, VA
    Posts
    880
    +1
    1

    Maiden Voyage Part 2 - No Oil Pressure Problems, but ..............

    I think the oil pressure regulator is OK. My pressure started at 90 psi and fell to 32 psi in about 10 minutes. After I was convinced that my oil pressure was OK, I began to give it a little more throttle. Some where between 4000 - 6000 rpm I began to throw a check engine light. When I pulled the code while the light was running - I was able to get a KNOCK SENSOR code out of the computer. I did remove all the normal octane and had just filled up with Chevron premium fuel. The fault did not occur at idle, but only with additional RPM. In addition, there was a slight noise from the hull at higher idle. I assume it is a backfire and not something else. I was a dull "thunk" from the engine compartment. I guess a backfire, because it doesn't happen at low RPM. I got a really good pin on the crank and camshafts for a good timing of the engine, but I assume that is where you guys are going to tell me to look.

    Just a few quick words on setup. Riva Gen II wheel in charger, a Riva External Intercooler, and 42# injectors. Stock exhaust. I guess I need to verify the sizing of the injectors. Any tips on how to do this?

    Other comments are welcome. Please steer me to the next troubleshooting step!


  2. #2
    thompsdw's Avatar
    Join Date
    Sep 2007
    Location
    Richmond, VA
    Posts
    880
    +1
    1
    Help?

  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    What is the oil pressure above 3500 RPM's.

  4. #4
    thompsdw's Avatar
    Join Date
    Sep 2007
    Location
    Richmond, VA
    Posts
    880
    +1
    1
    It was increasing with throttle. I didn't check it specifically at that rpm but my eyeball says about 40 psi.

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    OK thats good.. Now onto the Knock code..

    What is your compression? And did you do a leak down test? The backfire? sounds have me concerned.

  6. #6
    thompsdw's Avatar
    Join Date
    Sep 2007
    Location
    Richmond, VA
    Posts
    880
    +1
    1
    135-135-150. It has to be timing or fuel. I need to verify the injectors are 42s, but rich cylinders wouldn't cause a backfire, would it? If the timing is off, that's the only thing I can think of that would cause a backfire.

    Is there other noise that I could be confusing with a backfire that wouldn't be present at idle?

    I did also notice a little bogging at 3,500 rpm if that helps.

  7. #7
    Stockrxp's Avatar
    Join Date
    Aug 2010
    Location
    texas
    Posts
    1,009
    +1
    1
    Plugs?

  8. #8
    thompsdw's Avatar
    Join Date
    Sep 2007
    Location
    Richmond, VA
    Posts
    880
    +1
    1
    Btw - during the rebuild process, I did add the knock sensor pigtail to correct false positive knock sensor codes. Of course, that wouldn't explain the noise??????

  9. #9
    thompsdw's Avatar
    Join Date
    Sep 2007
    Location
    Richmond, VA
    Posts
    880
    +1
    1
    Quote Originally Posted by Stockrxp View Post
    Plugs?
    They were brand new, but that is an easy thing to check. Good idea.

  10. #10
    thompsdw's Avatar
    Join Date
    Sep 2007
    Location
    Richmond, VA
    Posts
    880
    +1
    1
    Bump for help.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP oil pressure problem
    By Coasty in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-07-2011, 03:39 PM
  2. Oil Pressure problem FX140
    By n888tx in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 11-09-2009, 07:52 PM
  3. 06 RXT oil pressure problem
    By 01xdime in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-10-2009, 01:12 PM
  4. oil pressure problem
    By 5Bulldogs in forum Open Discussion
    Replies: 0
    Last Post: 07-26-2008, 10:20 PM
  5. NEED HELP! with oil pressure problem!...
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 55
    Last Post: 11-21-2006, 05:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •