Results 1 to 7 of 7
  1. #1

    Join Date
    Sep 2011
    Location
    Brooklyn, NY
    Posts
    17

    15F Failing Cylinders

    I was out riding on my 2008 STX-15F on Friday, I was jumping waves and as I landed off a wave my ski just began running on 2 cylinders. I picked up a set of 4 new spark plugs as I figured that could be the problem. I have 57 hours and used original NGK CR9EK plugs. After changing plugs, whiule riding the smell of gas was present. Ski began running on 3 cylinders and would switch to 2 cylinders every few minutes. When I went into some rough patches the ski would jump from 2 cylinders to 3. I am having a waverunner mechanic check it out tomorrow. Just wondering if anyone had any idea what it could be.


  2. #2
    I will check ignition coil wires (to and from) for rubbing/shorting, their connection and spark plug wires/boots for any damage. Look for rub marks.

  3. #3
    Also, check your joint connectors along the wiring harness. The service manual shows where they are and what each of them do. I've had water get in one and cause an intermittent no start condition.

  4. #4

    Join Date
    Sep 2011
    Location
    Brooklyn, NY
    Posts
    17
    One of my coils was disconnected from the ignition coil distributor. Stupid problem and a really easy fix, thanks for the advice.

  5. #5

    Join Date
    Sep 2011
    Location
    Brooklyn, NY
    Posts
    17
    Strange how it just popped off while I was riding, once i winterize my ski I think I am going to tighten up all connections/bolts.

  6. #6

    Join Date
    Mar 2012
    Location
    North Texas
    Posts
    2
    New to the forum, but I think my 15-F is showing same symptoms.
    How do you diagnose that only running on less than 4 cylinders? I have intermittent problem where I lose power. It may be this exact problem.
    Where can I get access to manuals? Are they online anywhere?
    It is 2006, with ~150hours. It has same intermittent issue several years ago, then just came out of it for a year. Now it is back.
    Would love to diagnose and fix myself?
    I went through as many connectors as I could get access to. All seemed clean and with no corrosion. (fresh water only)
    Thanks,
    Wade

  7. #7

    Join Date
    Mar 2012
    Location
    North Texas
    Posts
    2
    I found an 04-05 manual, so should be enough help to check ignition coils.
    Won't know for a few weeks if I solved issue or not.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts STX 15f/12f Cylinder heads
    By smokeysevin in forum Kawasaki Classifieds
    Replies: 5
    Last Post: 05-12-2017, 09:55 AM
  2. New 15F cylinder for sale
    By YAMAPRO in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 07-21-2009, 11:53 AM
  3. WTB 15f cylinder block
    By kawasaki15f in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 05-14-2009, 12:23 PM
  4. 15f Head And Cylinder
    By bamatech in forum Kawasaki Classifieds
    Replies: 6
    Last Post: 10-26-2008, 03:07 PM
  5. WTB: 15F cylinders
    By pete71 in forum Kawasaki Classifieds
    Replies: 2
    Last Post: 10-15-2008, 01:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •