Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311

    R&D Tial Surge protector stuck open?

    Hey Guys has anyone had this happen the piston on my R&D surge is opening at start up basically I can start the ski and see the piston moving up releasing pressure??? HELP


  2. #2
    I dont have it, but a friend does and his does the same.

  3. #3
    blackvr's Avatar
    Join Date
    May 2007
    Location
    west palm beach
    Posts
    520
    +1
    70
    you have the wrong spring in it. not really a big deal. once you boost it will shut. sometimes it will affect throttle response. to get the correct spring just tell whoever you bought it from your vacuum at idle and they can get you correct one

  4. #4
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    you have the wrong spring in it. not really a big deal. once you boost it will shut. sometimes it will affect throttle response. to get the correct spring just tell whoever you bought it from your vacuum at idle and they can get you correct one
    I had it out Thursday doing some testing and it work fine then today just after warm up I started to throttle up and nothing that is when it started opening cant even get the ski to go over 3-4000 RPM all the air is going out the valve???

  5. #5
    blackvr's Avatar
    Join Date
    May 2007
    Location
    west palm beach
    Posts
    520
    +1
    70
    oh ok then its just stuck. does it close when you turn engine off?

  6. #6
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    yes it looks like it is closed I just dont know how far down the piston should go when off, I can just see what looks like a "O" ring

  7. #7
    if it closed you should'nt see the "o" ring

  8. #8
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    Ok I just took it off to take a look and it looks ok I can take my thumb with some pressure and push the "piston" up?? should it be that easy? I may try to take a video of it opening to see if you guys see anything

    what does that bolt at the top do just above the vacuum line?? is that a adjustment for pressure?

  9. #9
    i will get all the rest i need when im dead corkycat's Avatar
    Join Date
    Jan 2009
    Location
    uk
    Posts
    840
    +1
    1
    sounds to me like you dont have vacum at idle in the bov, check the spring is seated correctly also check you have the correct valve

  10. #10
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    Quote Originally Posted by shhr View Post
    I had it out Thursday doing some testing and it work fine then today just after warm up I started to throttle up and nothing that is when it started opening cant even get the ski to go over 3-4000 RPM all the air is going out the valve???
    Why don't you remove the vacuum line and then see if the ski will rev any higher ? That will narrow it down for sure.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New R&D Tial 50mm Surge Protector Kit for SHO/FZ
    By Green Hulk in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 07-29-2011, 07:04 PM
  2. Tested the RXT-X Supercharger Surge Protector Kit
    By iflyems in forum 4-Tec Performance
    Replies: 11
    Last Post: 09-19-2008, 01:15 AM
  3. Please help me :( Throttle stuck open 2000 GP800
    By SlowStang305 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-06-2008, 08:03 PM
  4. RXP 215 surge protector by RD performance
    By lincster in forum 4-Tec Performance
    Replies: 2
    Last Post: 01-29-2008, 03:05 AM
  5. Code 67 (stepping motor stuck open)
    By Rusty in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 02-24-2006, 07:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •