Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    Jerry, Jerry, Jerry jerryspringer's Avatar
    Join Date
    Oct 2008
    Posts
    248
    +1
    8

    rxtx 2009 cavitation - tips/help

    hey guys

    looking for some suggestions/tips

    My mate has a rxtx 2009 - 15 hours

    just added the following

    a kit x (les cooke drop in wheel)
    reflash ecu to 8400 rpm
    new wear ring
    new skat 3 blade 14/18 prop.

    prior to additions ski was running great however since the mods , i have cavitation issues on take off...this occurred the first ride after the mods ... i knew i didnt suck up anything but, i ve checked both the prop and wear ring and no signs of damage

    ski is fine after i take of, revs sit perfect, floats between 8280 - to 8340 max depending on conditions..

    hope you can help as it feels any gains i had by upgrading are being lost on poor take off..

    Although only low hours , i ve checked carbon seal (no water getting into hull)

    any other clues??

    im assuming prop set up as this is the newest addition ??


  2. #2
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Bellows and ring are weak. Change them out and get a bellow band. Makes all the difference. The upgrades will how the weakness of it. You are pulling air from within the hull. That prop has a much steeper root angle and has more 'pull' and thrust than the OEM prop. Make sense?

  3. #3
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,370
    +1
    980
    The first mod for any 2008/2009 RXT-X....pump tunnel reinforcement & a bilge pump.

    Next, check the alignment of the pumpshoe/driveshaft at the thru the hull fitting......if its off center then the carbon seal/floating ring/bellows could be sucking air.

    Last, the large rubber seal around the pump could be twisted and not sealing properly.

  4. #4
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    impeller cone rode up driveshaft?

  5. #5
    Quote Originally Posted by Sturm215 View Post
    impeller cone rode up driveshaft?
    Sorry, slightly off topic to the thread, but I have cavitation on one of my engines on my speedster200 and noticed one of the cones was up the shaft...how would that cause cavitation??

  6. #6
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    disturbing the flow of water...

  7. #7
    Quote Originally Posted by Sturm215 View Post
    disturbing the flow of water...
    so what would be the best way to prevent it from riding up the shaft again?? The cone is like a hard rubber if I remember correctly...??

  8. #8
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    alot of people ride with out it including me at this point.....

  9. #9
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by jerryspringer View Post
    hey guys

    looking for some suggestions/tips

    My mate has a rxtx 2009 - 15 hours

    just added the following

    a kit x (les cooke drop in wheel)
    reflash ecu to 8400 rpm
    new wear ring
    new skat 3 blade 14/18 prop.

    prior to additions ski was running great however since the mods , i have cavitation issues on take off...this occurred the first ride after the mods ... i knew i didnt suck up anything but, i ve checked both the prop and wear ring and no signs of damage

    ski is fine after i take of, revs sit perfect, floats between 8280 - to 8340 max depending on conditions..

    hope you can help as it feels any gains i had by upgrading are being lost on poor take off..

    Although only low hours , i ve checked carbon seal (no water getting into hull)

    any other clues??

    im assuming prop set up as this is the newest addition ??
    What intake grate are you running?

  10. #10
    Quote Originally Posted by MSRXP View Post
    Bellows and ring are weak. Change them out and get a bellow band. Makes all the difference. The upgrades will how the weakness of it. You are pulling air from within the hull. That prop has a much steeper root angle and has more 'pull' and thrust than the OEM prop. Make sense?

    +1 I was gonna post this (as Ive already had my experience in bellow troubles ). Mods are stressing the bellow more; giving cavitation on hole-shot, while everything else feels and runs just fine.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2009 yamaha Vxr With 40 . LOST Power and cavitation PLEASE HELP
    By mannyk727 in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 06-02-2015, 08:43 AM
  2. Bad Cavitation!!! Need Help!!
    By ArmyRXP in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-08-2008, 07:46 PM
  3. 96 spx 717 engine rebuild tip help please ("noob")
    By ryan*9 in forum 2-Stroke Performance
    Replies: 7
    Last Post: 07-17-2007, 11:07 PM
  4. new SS and cavitation...need help!
    By pet in forum 4-Tec Performance
    Replies: 44
    Last Post: 06-17-2007, 09:32 PM
  5. Cavitation Problem? Help!
    By NeverEndn in forum 4-Tec Performance
    Replies: 41
    Last Post: 08-10-2006, 10:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •