Results 1 to 7 of 7
  1. #1
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105

    Thanks Jay @ Atlantic Powersports

    I just wanted to send a special thanks to Jay over at Atlantic for the help on my Predator. He's some 2500 plus miles away from me yet his help is always better than anything I get locally or any quad forum.

    Thanks Again Bud!!!!


  2. #2
    2&4strokepolaristech's Avatar
    Join Date
    Aug 2006
    Location
    Oswego,NY
    Posts
    919
    +1
    6
    thanks for the kind words AL!! i try and help everyone out where ever i can. we do more than just PWC's here. We are the largest parts dealer for polaris in the world!!! we sell and service polaris atv's, rangers, PWC's and all BRP products(sea-doo,ski-doo,can-am,sport boats). any questions about any of the machine or any other manufactor please ask. i have over 20 years in the powersports business.

    Jay

  3. #3
    THE OFFICAL SUPERDUTY!!!!!! superduty's Avatar
    Join Date
    May 2006
    Location
    Webster, Texas
    Posts
    4,726
    +1
    5
    sorry al o/t, jay i have a 04 600 efi charged up the battery it ran down and while driving the whole thing just died is that the stator??

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    No problem. I'll take a shot at this though if you don't mind.
    Put a volt meter across the battery while it's running, if it's only showing battery voltage you know the system is not charging.
    I'd say it's a fuse or a bad voltage regulator.
    If memory serves me right the battery voltage should be around 12.5 and when it's running the voltage should increase to somewhere around 13.5-14 volts. With the headlight on it may not make the 14 volts.

  5. #5
    THE OFFICAL SUPERDUTY!!!!!! superduty's Avatar
    Join Date
    May 2006
    Location
    Webster, Texas
    Posts
    4,726
    +1
    5
    the last one i was working on had no fuses lol- i dont think this one does either yea i gotta check the voltage - but how do you tell if its the regualtor or stator?

  6. #6
    Altron's Avatar
    Join Date
    Sep 2006
    Location
    Klamath Falls, OR
    Posts
    91
    I have to second the thank you to Jay. He always has the time to answer my dumb questions and he is never to busy to talk to me. Like Al, I am over 2,500 miles away and he gives me the best sevice in the world. I wish the dealership I bought my PWC from was half as good.

  7. #7

    Join Date
    Oct 2006
    Location
    Beaver Falls, PA
    Posts
    281
    Jay You are the man.All your words of wisdom lead me to say this-----
    http://www.moviewavs.com/php/sounds/...le=iceburg.wav

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What Happened to Atlantic Powersports?
    By dfullercps in forum MSX/Matrix
    Replies: 10
    Last Post: 05-29-2009, 08:08 AM
  2. Thanks Jay!! Polaris RZR
    By ph2ocraft in forum Polaris Open Discussion
    Replies: 32
    Last Post: 11-08-2007, 10:51 AM
  3. Atlantic Powersports
    By starflight in forum Polaris Open Discussion
    Replies: 9
    Last Post: 08-09-2007, 01:00 AM
  4. Thanks Atlantic Power Sports!!!
    By ph2ocraft in forum Polaris Open Discussion
    Replies: 1
    Last Post: 03-23-2007, 09:49 AM
  5. Atlantic Powersports
    By ph2ocraft in forum Polaris Open Discussion
    Replies: 0
    Last Post: 11-02-2006, 12:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •