Results 1 to 8 of 8
  1. #1

    rrfpr question !!!!!!!!!!!

    I have some question for rude rrfpr , last time my ski install racing parts below :

    Rude 2 supercharger
    Rude rrfpr (set on base fuel pressure 60psi )
    Riva ecu
    Riva 50lb injector
    Riva valve train

    For this setting ! I am run very perfect , but now I remove rude 2 , install f5 turbo system , turbo tech begi system and walbro 255 fuel pump, I set will last tme on base fuel pressure 60 psi , start engine AFR was going 15.4 on idle rpm 1820 , I try to adjust go down afr to 12.5 on idle , but can no get the this result !!! When start engine adjust fpr main bolt screw to 45psi , AFR was 13.2 , this final I get best result !!

    Below is my ski afr table :

    Rpm. Afr. Boost psi
    1820. 13.2-13.6. -11
    2500. 12.5. -9
    3000. 12.6. -7
    3500. 13.9. -6
    4000. 14. -5
    4500. 14.3. -3
    5000. 13.5. -1
    5500. 12.6. 0
    6000. 11.9. 5
    6500. 11.2. 8
    7000. 10.5. 10
    7500. 10.3. 14
    8000. 10.2. 16
    8600. 10. 19

    My question is last time I using 2 rude , set on base fuel pressure run perfect , now I set on base fuel pressure 60 psi , afr 15.3 run lean ????? And on rpm 3500 to 4500 also lean , any guy ! Can help me !!!!! I don't know to happen matter !!!!!


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    .

  3. #3
    alex29573's Avatar
    Join Date
    Mar 2008
    Location
    miami
    Posts
    658
    +1
    1
    i just had this problem it turned out to be that i had one bad spark plug that was i guess semi-fouled.

    If you have an exhaust leak, or a cylinder misfiring your AFR will read falsely low.

  4. #4
    Mtuned's Avatar
    Join Date
    Aug 2010
    Location
    Orlando FL
    Posts
    724
    If you have the begi setup, you need to control the vac stuff vs boost stuff different.

  5. #5

  6. #6
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Those Riva 50s are likely locking up with the added fuel pressure. Could be just one injector but I would get rid of em!

  7. #7
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by dnielsen View Post
    Those Riva 50s are likely locking up with the added fuel pressure. Could be just one injector but I would get rid of em!
    +1. Get the Bosch or Lucas.

  8. #8
    Mtuned's Avatar
    Join Date
    Aug 2010
    Location
    Orlando FL
    Posts
    724
    Quote Originally Posted by MSRXP View Post
    +1. Get the Bosch or Lucas.

    I have the lucas 75s. Seem to be working great at 60 psi, and idle is great as well !

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RRFPR question
    By Vern in forum 4-Tec Performance
    Replies: 15
    Last Post: 09-06-2008, 11:52 AM
  2. rrfpr question
    By aviator921 in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-25-2008, 11:42 AM
  3. RRFPR Question
    By MPower in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-18-2008, 09:37 PM
  4. RRFPR Question
    By Brad Clarke in forum 4-Tec Performance
    Replies: 10
    Last Post: 03-08-2008, 02:58 AM
  5. RRFPR Question
    By Turbo Nick in forum 4-Tec Performance
    Replies: 49
    Last Post: 02-25-2008, 06:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •