Results 1 to 10 of 10
  1. #1
    TDR's Avatar
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    727
    +1
    10

    Fresh top end, low compression

    I have just finished off my putting my top end back together, fired it up tonight and did a compression test and only saw 100psi i only checked the first cylinder though. Should i be worried? or when i break the rings in the comp will boost up?


  2. #2
    Moderated
    Join Date
    Oct 2006
    Posts
    3,711
    comp should come up after breakin ........but did you pressure test it before you dropped in back in the hull?

  3. #3
    john zigler's Avatar
    Join Date
    Aug 2006
    Location
    WI
    Posts
    2,545
    +1
    33
    could also just be your guage is off.

    make sure all cyls match.

    and yes, re-check after break in.

  4. #4

    Join Date
    Nov 2009
    Location
    NC
    Posts
    783
    +1
    29
    What made you replace top end in the first place?
    I had low compression across all three cylinders, did top end, still had low compression. Turned out to be a blown out rear seal so I did a top end for nothing.
    I will now do pressure test before any top ends.

  5. #5
    Gauge is probably off

  6. #6
    TDR's Avatar
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    727
    +1
    10
    No i didnt pressure test i just put evefrything back together. I did the top end because i was around 100-105 psi on all cylinders and thought that the top end would fix it

  7. #7
    Moderated
    Join Date
    Oct 2006
    Posts
    3,711
    ALWAYS pressure test!!!!!!!!!!!!!!

  8. #8
    TDR's Avatar
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    727
    +1
    10
    The resonator has a hole in it would this affect comp?

  9. #9
    Superman! fivespeedsteed's Avatar
    Join Date
    May 2010
    Location
    Midlothian VA
    Posts
    1,058
    +1
    14
    No, to pressure test you block off the carb holes or the intake and the exhaust manifold, so your basically pressure testing just the long block with the header on it. Mine was low too I did a top end then pressure tested it and had to tear it all back down, always pressure test, too late now but you know for future builds. Lowell porting makes a great kit for pressure testing

  10. #10
    TDR's Avatar
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    727
    +1
    10
    Yeah i was reading up in your build and saw how you pressure tested your ski. Exactly its to late now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1200 LTDRebuilt top end still low compression
    By ronqqq in forum Yamaha How To & FAQs
    Replies: 3
    Last Post: 07-01-2016, 06:28 PM
  2. Top End Rebuild - compression ring seating question
    By polaris780slt in forum Polaris Open Discussion
    Replies: 15
    Last Post: 08-14-2012, 07:00 PM
  3. Top End Rebuild Compression Issues (02 GP1200R)
    By Johnny5 in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 11-04-2010, 11:18 PM
  4. 99 SLTH - Top End Runs great, bogs down at low RPM
    By thiagoavila in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-29-2010, 12:02 PM
  5. bad compression #'s, but good top end?
    By mibunkerking in forum 2-Stroke Performance
    Replies: 55
    Last Post: 06-10-2009, 08:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •