Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1
    tasosz's Avatar
    Join Date
    Aug 2007
    Location
    Kavala Greece
    Posts
    36

    Angry Riva stage 3 FZS stock piston broke!

    I went for last seasonís ride the day before yesterday. Air temp was 48 F. Warmed up the engine and I was riding for ten minutes at 5500rpm. Then I went up to 7500rpm and after two minutes I lost power and felt the motor was running with three cylinders. I stopped the engine immediately and pulled off the seat. Smoke,smell and two liters of engine oil inside the bilge.
    I ended up with No 2 piston in many pieces, one bent valve, head and cylinder destroyed and a nice hole to the case so far. Can someone tell me this damage caused from lean fuel mixture or a piston fatigue? I ride it for two years with stage 3 and I had zero problems till now.


    Click image for larger version. 

Name:	IMG_0270.jpg 
Views:	227 
Size:	92.5 KB 
ID:	258364Click image for larger version. 

Name:	IMG_0271.jpg 
Views:	140 
Size:	75.7 KB 
ID:	258363Click image for larger version. 

Name:	IMG_0272.jpg 
Views:	158 
Size:	109.7 KB 
ID:	258362


  2. #2
    Got any pictures of whats left of the piston? the larger pieces (if any...).

    Number two runs leanest of all cylinders. Water comes in the back of the block, leaving it to be the second hottest cylinder (next to number 1). But due to intake manifold design runs leaner than number 1. Its the most likely cylinder to fail and why it is often recommended to keep afr numbers below 12.0. Its just an average reading, if you read 12.5, #1 and #4 could be 12.4 and 12.5 with #3 around 12.7 and #2 up to 13.0 (random numbers but it gets the point across...)

    Unfortunate to see...how many hours?

  3. #3
    locito007's Avatar
    Join Date
    Oct 2011
    Location
    Sydney Australia
    Posts
    66
    +1
    1
    My friend that looks like a piston and or con rod issue! A possible hair line fracture which may have damaged at the high rpms! Oh no poor crank case that is why the oil was going into the bilge pump!! I cannot see from these photos but what does the connection rod look like? Is that Bent or broken sine that is what was the case for my MSX 140 I am rebuilding. All I can say is hot rod con rods! Time to start a top to bottom rebuild to get that ski humming at 7500 rpms again!!! I feel your pain to see the damage...

  4. #4
    Banned User
    Join Date
    May 2006
    Posts
    1,329
    +1
    152
    Quote Originally Posted by tasosz View Post
    I went for last season’s ride the day before yesterday. Air temp was 48 F. Warmed up the engine and I was riding for ten minutes at 5500rpm. Then I went up to 7500rpm and after two minutes I lost power and felt the motor was running with three cylinders. I stopped the engine immediately and pulled off the seat. Smoke,smell and two liters of engine oil inside the bilge.
    I ended up with No 2 piston in many pieces, one bent valve, head and cylinder destroyed and a nice hole to the case so far. Can someone tell me this damage caused from lean fuel mixture or a piston fatigue? I ride it for two years with stage 3 and I had zero problems till now.


    Click image for larger version. 

Name:	IMG_0270.jpg 
Views:	227 
Size:	92.5 KB 
ID:	258364Click image for larger version. 

Name:	IMG_0271.jpg 
Views:	140 
Size:	75.7 KB 
ID:	258363Click image for larger version. 

Name:	IMG_0272.jpg 
Views:	158 
Size:	109.7 KB 
ID:	258362
    Your not saying it was a riva piston it was a stock piston with a riva stage 3 set up correct? Sucks sorry to hear maybe you can find the cause

  5. #5
    Can someone tell me this damage caused from lean fuel mixture or a piston fatigue?

    Combination of both, unless there is evidence to be seen on the piston. Stock pistons will only take the heat for so long.

  6. #6
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    The other cylinders look good and not lean.......its possable the wrist pin failed on the piston itself and git hit by a valve and rattled around.


    I would think if it was lean signs of it would be on other pistons and cylinders

  7. #7
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Hydrolock looks like on head I see signs of water.....?

  8. #8
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,414
    +1
    76
    Look like the piston just failed.
    You can see sign on the right wrist pin that it "wiggle" around it.
    Probably started to crack around and shattered in piece.

    Just look on the right side of the cylinder wall, should have more damage if it is the case.

  9. #9
    gordon lasiter #328's Avatar
    Join Date
    Aug 2008
    Location
    katy, texas , United States
    Posts
    1,647
    +1
    28
    that totally stinks.
    hopefully you can locate a new case for a reasonable price and rebuild it with aftermarket internals.

  10. #10
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,414
    +1
    76
    Not judging you, but wasn't the Riva Stage 3 required internal upgrade?
    If yes, 2 years holding with stock internal is not that bad.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB looking for 1 sho- fz stock piston
    By 305coco in forum Yamaha Classifieds
    Replies: 3
    Last Post: 04-18-2016, 11:06 PM
  2. FS 3 Riva Pistons for Yamaha FZ Stock compression and Bore
    By BAYOU FZR in forum Yamaha Classifieds
    Replies: 3
    Last Post: 07-02-2013, 04:05 PM
  3. Riva Stage III FZ kit released by Riva
    By Green Hulk in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 04-16-2010, 11:17 AM
  4. Stock VS Riva Stage 3 VS CNC B Kit impeller weights
    By Green Hulk in forum 4-Tec Performance
    Replies: 38
    Last Post: 11-30-2006, 08:30 AM
  5. Anybody Run a Riva Stage I with the Stock Prop?
    By Sirhc7897 in forum 4-Tec Performance
    Replies: 13
    Last Post: 02-01-2006, 12:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •