Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1

    Seadoo rxtx rebuilt engine rpm problem

    I'm having problems with my rebuilt engine, I upgraded my pistons to rivA 9.5.1 oversize .10 and changed to fizzle intercooler. Lost 440 rpm compare to the previous setup rivA stg3. I already checked all clamps etc for leaks, pistons showing 150-150-150,charger slip checked, afr inline, my current speed [email protected] Any ideas?


  2. #2
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    809
    what was previous speed? what charger? what boost? did you use the supplied bolts and washers to plug the threaded holes in the side of the intercooler? did your stock intercooler block-off plug shoot out the brass plugs? it seems like if you pitched the prop for 8600 you would be at around 80 mph, which is average for a stage 3 setup.

  3. #3
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Check for boost leaks, make sure charger is not slipping. Double check the cooling hoses to the IC for propper routing, low or no water flow equals low or no effecient IC. What else was changed during rebuild.

  4. #4
    Mtuned's Avatar
    Join Date
    Aug 2010
    Location
    Orlando FL
    Posts
    724
    What ic did you have?

  5. #5
    Quote Originally Posted by JFizzleJR View Post
    what was previous speed? what charger? what boost? did you use the supplied bolts and washers to plug the threaded holes in the side of the intercooler? did your stock intercooler block-off plug shoot out the brass plugs? it seems like if you pitched the prop for 8600 you would be at around 80 mph, which is average for a stage 3 setup.

    08 RXT-X /riva train valve set/ported head & block/riva 9.5.1 pistons/riva ECU/riva 50Ib injector/riva pro-x impeller/riva RRFPR/Fizzle intercooler with bleed mod/riva pro blow-off/riva catch can/riva water box/riva rear exhaust/ riva manifold kit/riva ride plate/R&D intake grate/riva reduction nozzle 83mm/riva 15/22r/riva open loop sys/custom 4" air filter & vents/riva ss wear ring/Mtx-L AFR/apexi boost meter/mc spring washer/riva cluth washer/riva sponsons/riva pro-series o.p.a.s/ R&D anti cavitation cone/speedfreak nose/speedfreak head band mod/riva extension rod/custom gauage pod/rule pump/ GPS 78.6 mph @ 8450
    RPM- Garmin c76

    This was the previous set up excluding; rivA 9.5.1 oversize pistons, fizzle intercooler, rivA grate, stock cone, solas nose, head band.

    I used all the supplied brass fitting, I installed the fizzle as per the updated instruction.

  6. #6
    Eastside Powersports Slow 91's Avatar
    Join Date
    Sep 2008
    Location
    River Crew CT
    Posts
    4,248
    +1
    544
    400 is alot of rpm to be down. im guessing its going to be something very obvious.

  7. #7
    Quote Originally Posted by dnielsen View Post
    Check for boost leaks, make sure charger is not slipping. Double check the cooling hoses to the IC for propper routing, low or no water flow equals low or no effecient IC. What else was changed during rebuild.
    I checked all for leaks with no luck, charger slip 15lb, rivA open loop as per rivA instruction with water filter into ic front fitting.

    08 RXT-X /riva train valve set/ported head & block/riva 9.5.1 pistons/riva ECU/riva 50Ib injector/riva pro-x impeller/riva RRFPR/Fizzle intercooler with bleed mod/riva pro blow-off/riva catch can/riva water box/riva rear exhaust/ riva manifold kit/riva ride plate/R&D intake grate/riva reduction nozzle 83mm/riva 15/22r/riva open loop sys/custom 4" air filter & vents/riva ss wear ring/Mtx-L AFR/apexi boost meter/mc spring washer/riva cluth washer/riva sponsons/riva pro-series o.p.a.s/ R&D anti cavitation cone/speedfreak nose/speedfreak head band mod/riva extension rod/custom gauage pod/rule pump/ GPS 78.6 mph @ 8450
    RPM- Garmin c76

    This was the previous set up excluding; rivA 9.5.1/ 0.10 oversize pistons, fizzle intercooler, rivA grate, stock cone, solas nose, head band.

  8. #8
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    If you think everything is setup and functioning correctly then just depitch some and see what happens. You didn't really add any power it looks.

  9. #9
    Quote Originally Posted by Mtuned View Post
    What ic did you have?
    I had stock ic in the previous setup, I blow 3 stock ic's over 70 racing hours, the 3 rd one blow from the inside & costed me my engine so i decided to go with the fizzle/ water bleed option ic for that extra boost.

  10. #10
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by Ocman View Post
    If you think everything is setup and functioning correctly then just depitch some and see what happens. You didn't really add any power it looks.
    He really should not have to as he did not reduce power either. Atleast not 400+ rpm worth.
    Hate for him to put a bandaid over a sore.


    Ali welcome to the forum.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems with newly rebuilt engine
    By Snipescastle2 in forum 2-Stroke Performance
    Replies: 59
    Last Post: 09-22-2017, 08:37 AM
  2. 951 Engine RPM problems when hot, Great when cold
    By KCseadoo in forum 2-Stroke Performance
    Replies: 5
    Last Post: 06-26-2012, 12:28 PM
  3. 2006 Seadoo Rxp Engine,RPM Problem. Please Help!
    By gotach in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-22-2010, 12:16 AM
  4. Engine rpm problem
    By monaroman76 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-02-2008, 08:36 AM
  5. 2002 Seadoo Sportster LE engine/impeller problem?
    By RogerinSC in forum Sea Doo Sport Boats
    Replies: 4
    Last Post: 08-07-2007, 11:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •