Results 1 to 5 of 5
  1. #1

    Question Fogging kit stopping bov install HELP!!!

    Hi guys I need advice off use who have the riva racing bov kit and also a fogging kit installed on your rxp and advise me how to install the bov without interrupting the fogging kit....pics will be a real hand and much appreciated plz help I won't it installed thanx


  2. #2

  3. #3
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134
    Quote Originally Posted by Rxp270hp View Post
    Hi guys I need advice off use who have the riva racing bov kit and also a fogging kit installed on your rxp and advise me how to install the bov without interrupting the fogging kit....pics will be a real hand and much appreciated plz help I won't it installed thanx

    Assuming you have an issue because the Riva instructions direct you to use one of the 3 oem nipples to attach vacuum line, which are all used when running the fogging kit?
    Are you still running the OEM internal intercooler? I assume so as if you were not it would be as simple as using one of the holes in the block off plate to install a hose barb and take off from there.


    Let's see how long it takes for everyone to chime in and tell you the easiest and "best" solution is not to run the BOV

  4. #4
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    [QUOTE=Sayers;1837614Let's see how long it takes for everyone to chime in and tell you the easiest and "best" solution is not to run the BOV [/QUOTE]

    +1 you won't get the bov sound like a turbo would, there's no point to run a bov in this application.

  5. #5
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by jhill19 View Post
    +1 you won't get the bov sound like a turbo would, there's no point to run a bov in this application.
    It will cause accelerated wear of your clutch and bearings. Leave it off. Unless you are running a BIG charger, you WILL NOT get the sound you are looking for. Remove it and be done with it. It is pointless on a SC gear driven application.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva BOV kit questions / Install help South Florida.
    By ocod in forum Yamaha PWC Performance (4-stroke)
    Replies: 15
    Last Post: 06-04-2016, 12:11 PM
  2. Install help with R&D Surge Protector Kit
    By Sam SHO in forum Yamaha PWC Performance (4-stroke)
    Replies: 26
    Last Post: 05-19-2016, 01:12 PM
  3. Single carb primer kit install----- help!
    By MatthewZ in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-16-2013, 02:45 PM
  4. Bov instal problem plz help:(
    By Rxp270hp in forum 4-Tec Performance
    Replies: 11
    Last Post: 11-11-2011, 09:16 PM
  5. S/C IMP & BOV INSTALLED
    By CRAZEDRXP in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-07-2005, 07:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •