Results 1 to 6 of 6
  1. #1
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30

    Bilge Pump and threw hull fitting

    Hey as the title states im looking for a bilge pump with the fitting that goes threw the hull. wanting to add it to my SLT 750.


  2. #2
    Every adventure comes to an end........ Not Today! wreckingball's Avatar
    Join Date
    Sep 2009
    Location
    San Diego, California, United States
    Posts
    1,347
    +1
    2
    You cam buy everything you need at a West Marine store for about $100.

  3. #3
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    Ya ive found things online just dont want to spend 100 dollars figured id check here see if anyone had one they wanted to part with

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    29
    Contact Zigler. i think he sells the bilge pump for around $25. then all you need is the 3/4" hose and a 3/4" fitting. More like $50 (Hell, ask him about those too)

  5. #5
    john zigler's Avatar
    Join Date
    Aug 2006
    Location
    WI
    Posts
    2,545
    +1
    33
    i have everything here. new & used......

    zig

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Yup......see John

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. bilge pump and grease fitting
    By jonnyboy910 in forum Polaris PWC Performance
    Replies: 2
    Last Post: 05-19-2015, 11:38 AM
  2. 2000 Polaris Genesis bilge pump and reverse now working
    By jls7707 in forum Polaris PWC Performance
    Replies: 8
    Last Post: 08-14-2011, 09:24 PM
  3. 95 polaris 750SL bilge pump and spill installation
    By mogyver69 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 06-12-2010, 10:12 AM
  4. What location are people installing bilge pumps on X4 hulls?
    By caliburst in forum 2-Stroke Performance
    Replies: 26
    Last Post: 06-11-2009, 09:18 AM
  5. Bilge pump and trim have no voltage after start
    By turk0004 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-02-2007, 09:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •