Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    Stuck shaft any more ideas?

    Tilted ski down and sprayed some rust breaker down shaft and let sit. The put some straps on and put tension on pump to pull out and nothing has moved. Has a drive shaft been so stuck it needs to be cut? If I have to take out intermediate bearing does the motor have to be moved forward or the bulkhead removed? Any help would be awesome! Beers on me.. 2008 SHO picked up for 4k from a friend everything if fine but the pump and its got a brand new SC on it. Oh yea came with trailer.


  2. #2
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    Wow that seems pretty stuck. I have had success using the pry tabs on the pump to get out a sticky shaft.

  3. #3
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Do you mean the whole pump won't come out?

  4. #4
    Addicted Member 5001craig's Avatar
    Join Date
    Jul 2007
    Location
    Northeast Indiana
    Posts
    2,924
    +1
    11
    Shaft has splines on it--don't see how the shaft could be stuck. The pump, however, gets stuck pretty tight with the sealant. As Mike said above, pry on the tabs between stator and the liner.

  5. #5
    Ive had the best luck with a large heel bar in between the casting for the strainer and the transom plate, the little tabs...dont hold up very well.

  6. #6
    The pump is loose, the only thing holding now is the shaft and it won't budge....

  7. #7
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137
    Quote Originally Posted by gashog301 View Post
    The pump is loose, the only thing holding now is the shaft and it won't budge....
    Are you sure you have all of the correct bolts out ?

  8. #8
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    You have three choices.
    1) tie the pump to a tree and try pulling it out with your vehicle.
    2) Remove the engine and punch the center out of the spider coupler then drive the end of to driveshaft out of the midshaft.
    3) Cut the shaft under the thru-hull hose.

  9. #9
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    There's a small easy to miss bolt on the left side of the pump that may be causing you trouble. Like I said, very easy to miss.

  10. #10
    Beerdart 1. tried that 2. allot of work 3. prob do that
    Mike FZR that bolt is out

    Can i just take out the bulkhead to get to Inter. bearing or do I have to move motor forward?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Anyone have any other ideas to get my damn GTX movin?
    By camar0 in forum 4-Tec Performance
    Replies: 42
    Last Post: 08-14-2007, 01:56 PM
  2. any good ideas
    By excess in forum 4-Tec Performance
    Replies: 0
    Last Post: 09-23-2006, 01:31 PM
  3. What......does anybody work any more?
    By peteshauling in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 08-02-2006, 12:39 PM
  4. Any More Free Speed!?!
    By FireFox in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-16-2006, 04:58 PM
  5. Any good ideas on how to....?
    By GeoRXT in forum Yamaha Open Discussion
    Replies: 18
    Last Post: 04-21-2006, 08:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •