Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33

    Has anyone installed a X ski EX IC with success in a older ski?

    I have read many a post were members were intalling the X skis EX IC on there older ski, but no follow up with any results?

    Did anybody have good luck with it? Or did they all blow out without using the T water route?

    thanks,


  2. #2
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,691
    +1
    40
    Hi,I have use the x cooler on my GTX project.
    Check here for pics!
    http://www.greenhulk.net/forums/show...=144050&page=3

  3. #3
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    The key thing I need is how to do the water routing? with a J pipe set up?
    for now I have been told to a T from the pump to the intake side of the IC and the front of the exhaust manifold. then drill out the pump for the exit of the IC,

  4. #4
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,849
    +1
    742
    I have a 2008 external X model IC and bracket on my 05 GTX/SC 185. Huge difference in acceleration and performance. See signature below.

  5. #5
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by skigolfnut View Post
    The key thing I need is how to do the water routing? with a J pipe set up?
    for now I have been told to a T from the pump to the intake side of the IC and the front of the exhaust manifold. then drill out the pump for the exit of the IC,
    That is the way I would do it.
    I would use the x tee.
    Don't change anything on your j pipe. It will get the water from exhaust manifold.
    And excess still going from top of j pipe to pump tunnel.

  6. #6
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    Many Thanks, I will go with the T like the X ski, and drill out the extra outlet at the pump and have the water outlet from the intercooler go overboard thru the pump,
    If it doesent work, I can always go back to no T and use my shut off valve to regulate the inlet pressure and drill out the pisser a little more so it doesn't build up much pressure,
    I am going to hook it all up tomorrow and install a bilge pump, the AFR gauge, the RRFPR, and hopefully I can now spin that 15/20 I have had on there to the right RPM's
    Thanks again,

  7. #7
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    What restrictor do you have in pump?
    Might inlarge it to x size if not already.
    Are you running the bleed on ic?

  8. #8
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    The hose coming in from the pump had a red band around it, is the restricter in the transom part of the pump? do I drill it out?
    I am going to make a pisser for the bleed on the IC, I was going to use one of my Polaris pissers that I use on my tripple piped 785 pro, that way I could see it flowing while I am running,

  9. #9
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    When you take pump off.. you see washer with yellow rubber guard for 215 set up and Green for 255 set up.

  10. #10
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    The restrictor is a washer in between pump and shoe.
    It should be yellow.
    You could try it and if exhaust is not getting enough water then open the washer up.
    I don't recall exact measurements.
    I think the difference on 215 and 255 is 1 mm.

    If was me I would open the washer up per the X ski.
    It makes since with T fitting.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Has anyone installed an MFI on a SL ski?
    By Mr. Matrix in forum Polaris Open Discussion
    Replies: 70
    Last Post: 09-06-2016, 10:57 PM
  2. Has anyone installed a headlight or nav lights on their ski?
    By VXRPete in forum Yamaha Open Discussion
    Replies: 13
    Last Post: 09-16-2015, 07:21 AM
  3. has anyone installed a bov on fzr
    By jusloungin in forum Yamaha PWC Performance (4-stroke)
    Replies: 48
    Last Post: 03-17-2010, 09:33 PM
  4. Replies: 10
    Last Post: 07-27-2009, 09:43 PM
  5. has anyone fallen off your ski?????
    By ugadawg131 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 12-11-2006, 07:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •