Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1
    excess's Avatar
    Join Date
    May 2006
    Location
    Miami, FL
    Posts
    338

    Cleaned my intercooler today like jerry but wanted to know if this is normal

    I set it up exactly as jerry has it except my ic was facing upwards, now after the bilge had been on for a while and i disconnected it, i noticed some of the coil cleen stuff was sitting at the bottom of the air passages, is this normal? I thought that was closed off and they were two seperate peices?

    Maybe it had to do with it being upward but even then, I dont know the exact workings of it inside the core so I dont know if this is perfectaly normal or not.

    My concern is that i thought it had a lot of sand along the walls of the air side and am now thinking this could be contributing


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    If you have fluid in the air side of it that would indicate a leak

    Did you spill any in there or did it leak thru?

  3. #3
    excess's Avatar
    Join Date
    May 2006
    Location
    Miami, FL
    Posts
    338
    it leaks through, when im running just the water through it you can see it dripping out the middle of the core on both sides????

    I was going to start putting things back together should i call them up

  4. #4
    excess's Avatar
    Join Date
    May 2006
    Location
    Miami, FL
    Posts
    338
    the ic is practically brand new and its not a storybut what would my approach be to riva on this?

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    I believe there is a 30 day warranty on those IC's. Its kind of a hard part to warranty because many people will ride in salt water and not flush properly and that just eats those aluminum coils up. Give Bubba at Riva a call and see what he says.

  6. #6
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Yeah jerry's right. Thirty days after purchase.
    Last edited by Alex13; 01-04-2007 at 05:32 PM.

  7. #7
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Is this a problem with the intercoolers or the conditions they are ridin through EX: salt water,,sand,,ECT??

    Been reading more and more about these leaks

  8. #8
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Quote Originally Posted by Snoman View Post
    Is this a problem with the intercoolers or the conditions they are ridin through EX: salt water,,sand,,ECT??

    Been reading more and more about these leaks
    It has alot to do with how you wash out and care for your ski.

  9. #9
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    Salt Away is a must for these IC's, huh?

  10. #10
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by Alex13 View Post
    It has alot to do with how you wash out and care for your ski.
    I ride fresh water only ..what would be the best thing to do??
    I guess i sound like a rookie here asking all these questions but 1600
    for a new intrercooler is alot of money to put out everytime the inter cooler leaks.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cleaned my intercooler at 15 hours with a 1/2 gal gas reset BOV to 2.5 threads
    By rod_rod in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 08-24-2015, 01:11 AM
  2. Would like to know if everything is working on my 2008 rxp-x 255
    By travis ingram in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-04-2014, 08:57 AM
  3. I bought a VTS and i want to know if it work with my ski
    By stevie183 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-09-2013, 10:42 PM
  4. I bought a VTS and i want to know if it work with my ski
    By stevie183 in forum Open Discussion
    Replies: 1
    Last Post: 06-09-2013, 10:42 PM
  5. My Genisis doesn't doesn't want to idle
    By cowranch 2006 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-25-2010, 10:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •