Results 1 to 3 of 3
  1. #1

    pulling the engine on a wr500d

    this is my first experiance working on a jet ski . my problem is after removing the 3 motor mount bolts, the large water hose,gas tank i can't get motor to slide forward more than a half inch. it feels like it's hitting something solid. i can lift the engine up a little with my hoist but it won't go forward enough to clear the shaft coupler.i must be missing something only i can't figure out what. can somebody out there help me out with this? many thanks for your help if you can.

  2. #2
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    League City, Texas
    welcome to the forum

  3. #3
    thanks for all the help i didn't get. i found the problem anyway. i found out there's 4 mounting bolts instead of 3. bye..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pulling bottom plate off fuji engine
    By Djaypro in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-21-2011, 08:55 PM
  2. pulling engine
    By rjeffery in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-01-2011, 11:55 PM
  3. Help pulling engine
    By schmc5 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 12-16-2010, 12:58 PM
  4. Pulling engine
    By Muckafoonee in forum Polaris Open Discussion
    Replies: 17
    Last Post: 06-30-2009, 10:14 PM
  5. Pulling Engine on My SLX?!?!
    By TechSLX in forum Polaris How To & FAQs
    Replies: 14
    Last Post: 09-24-2008, 10:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts