Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Rebuilt x-charger = hammer on it tomorrow

    About to reinstall my freshly rebuilt x-charger (by Jerry) with the "best" washers, Viton seal and set at 15lbs slip. Hauling this bitch out to the cold CO river tomorrow morning.
    Cold, flat azz water, air temps should be at least in the 50s and some downstream current just south of the Hoover Dam should yield me some VERY high 70s-80ish mph....hopefully my driveshaft bellow doesnt wimp out too badly tomorrow


  2. #2
    In fact....this should be a good ride to wear my scary pumpkin face stocking over my head

  3. #3
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Bellows should be frozen solid!! Good luck!

  4. #4
    Frozen?

    Yea I'll be riding behind the seat on my toenails and sport'n a chubby, lmfao!

  5. #5
    Went to the river and it pulled off a "disappointing" best of 78.9...winds were somewhat gusty, so the water was just a little less than perfect. Got all my RPMs back with the charger rebuild, so thats great.
    Besides the tired charger, i knew I had a driveshaft bellow getting weak on me....left the river, picked up my O-rings from the dealer to slide into the grooves of the bellow. Found the clamps around the bellow to be slightly loose and also my floating ring was a little frozen/jammed on the shaft/C-clip. Was never that bound up before. Reinstalled everything along with a new c-clip and rode it on the lake (instead of the river). Winds there were even more gusty and had almost shitty water. Now, with the tweaked bellow boot, I got all my torque/thrust back....so now it totally feels like normal again. But with the less than ideal water, I was only able to grab 77.3. Not too bad considering the water and gusty wind pushing me everywhere. Gonna try and get out again this week and grab 79.X

  6. #6
    Quote Originally Posted by blkturbo! View Post
    ...i knew I had a driveshaft bellow getting weak on me....left the river, picked up my O-rings from the dealer to slide into the grooves of the bellow. Found the clamps around the bellow to be slightly loose. Reinstalled everything and rode it on the lake (instead of the river). Winds there were even more gusty and had almost shitty water. Now, with the tweaked bellow boot, I got all my torque/thrust back. But with the less than ideal water, I was only able to grab 77.3. Not too bad considering the water and gusty wind pushing me everywhere. Gonna try and get out again this week and grab 79.X
    Got my speed on the river yesterday that I was hoping to get last week. 80.1 with the rebuilt charger and the bellow tended to More minor mods to come. Hoping to inch my way to 82 with the speedfreeks plate and eventually my 4in air intake plus other really minor bullshit mods

  7. #7
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Please, please, PLEASE tell me I am reading your signature wrong...3" intake?

  8. #8
    rxpvic's Avatar
    Join Date
    Jun 2006
    Location
    Tampa, Florida
    Posts
    258
    +1
    17
    Quote Originally Posted by blkturbo! View Post
    Got my speed on the river yesterday that I was hoping to get last week. 80.1 with the rebuilt charger and the bellow tended to More minor mods to come. Hoping to inch my way to 82 with the speedfreeks plate and eventually my 4in air intake plus other really minor bullshit mods
    Great speed with what mods you have, keep us posted on your new speeds when you change you rideplate from jims to speedfreaks. Cant wait to see if there is a big difference. Also did you ever check your afr's with your setup?

  9. #9
    Quote Originally Posted by Danny View Post
    Please, please, PLEASE tell me I am reading your signature wrong...3" intake?
    haha, yes i am STILL using my 3in intake. I have the 4in kanaflex ready to go, but im too nervous to install it and find out the hard way that it will throw me too lean. Actually, I have no idea if im too lean or too rich since I have NOT checked my air/fuel ratio yet either. Im still at a point where im not monitoring anything yet and so thats why im playing safe and leaving the 3in to choke it right now.

    What im stalling on is the new plug and play monitoring device to be finished from the Dyno Research guys. However, at the moment my plugs do seem to burn nicely. I change them roughly every 15-20hrs and they always come out looking as they are on point. Not black and rich, and not burnt white to a crisp as though lean. They appear "middle of the road" as much as i can tell.

  10. #10
    Mtuned's Avatar
    Join Date
    Aug 2010
    Location
    Orlando FL
    Posts
    724
    Impressive numbers..

    What nozzle do you have? WIth my 15/20 on 83mm ring i was on the limiter at 80MPH. Same grate, same plate. If your close to limiter you should repitch.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 12-18-2012, 01:36 AM
  2. Replies: 14
    Last Post: 06-14-2012, 10:15 PM
  3. FS x-charger, like new. It has maybe 8 hrs on it.
    By vspec1 in forum Sea Doo Classifieds
    Replies: 5
    Last Post: 05-14-2011, 07:17 PM
  4. FS FS: Super Charger with 40hrs on it.
    By mini73 in forum Sea Doo Classifieds
    Replies: 7
    Last Post: 03-02-2011, 07:44 AM
  5. FS FEELERS 2 rude charger 4 hrs on it
    By trent_girardrxp in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 10-30-2010, 05:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •