Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    JohnCiccarelli's Avatar
    Join Date
    Oct 2008
    Location
    Bay Tree Lakes, NC
    Posts
    292

    2002 GTX-DI Motor in a 2003 XP-DI

    I just replaced the motor in my 2003 XP-DI and all was going fine until I went to install the fuel distributor (Mounts on top of Injectors). The mounting holes are in a different location. I noticed other differences in the head, but I did not expect to find the holes in a different location. I guess that this means that the Fuel distributors are different. Does any one have any experience with this? I have the fuel distributor from the 2002, but the holes for the hoses are different sizes, so this one will not work.

    The only thing that I can think to do is drill new holes in my original fuel distributor or replace the head. I don't like either solution.

    Any Ideas? John


  2. #2
    Mtuned's Avatar
    Join Date
    Aug 2010
    Location
    Orlando FL
    Posts
    724
    Post up some pics? I was certain the 02+ Di motors were all the same? What color are the air injectors on each?

  3. #3
    JohnCiccarelli's Avatar
    Join Date
    Oct 2008
    Location
    Bay Tree Lakes, NC
    Posts
    292
    Quote Originally Posted by Mtuned View Post
    Post up some pics? I was certain the 02+ Di motors were all the same? What color are the air injectors on each?
    Maybe it is an earlier motor, but I was told it came out of an 02. It is definately different then my 03. My injectors are grey. The injectors on this motor are larger and black.

    At this point all I want to do is make this work. What is the best solution?

  4. #4
    Mtuned's Avatar
    Join Date
    Aug 2010
    Location
    Orlando FL
    Posts
    724
    Quote Originally Posted by JohnCiccarelli View Post
    Maybe it is an earlier motor, but I was told it came out of an 02. It is definately different then my 03. My injectors are grey. The injectors on this motor are larger and black.

    At this point all I want to do is make this work. What is the best solution?
    You have a 01 motor.. 2001’s have black injectors. Now your in a pickle, you need the mpem from the ski with the motor with black injectors.

    Different ports in the motor 6 Port Vs 5 Port, Different cyl heads. Your best bet would be to swap MPEM, and and fuel distributor from donor ski!

  5. #5
    JohnCiccarelli's Avatar
    Join Date
    Oct 2008
    Location
    Bay Tree Lakes, NC
    Posts
    292
    Quote Originally Posted by Mtuned View Post
    You have a 01 motor.. 2001’s have black injectors. Now your in a pickle, you need the mpem from the ski with the motor with black injectors.

    Different ports in the motor 6 Port Vs 5 Port, Different cyl heads. Your best bet would be to swap MPEM, and and fuel distributor from donor ski!
    The Fuel lines on my 03 XP-DI do not fit the new fuel distributor. What would be the problem of using the Grey Injectors with my MPEM and fuel distributor and drill new holes so I can mount the fuel distributor on the old style head?

  6. #6
    That will not work; the ports and cylinder arrangement on the late motors are tuned to the later MPEM's. At best, it won't run right. At worst, you will blow it up in a short amount of time.

  7. #7
    JohnCiccarelli's Avatar
    Join Date
    Oct 2008
    Location
    Bay Tree Lakes, NC
    Posts
    292
    Quote Originally Posted by Sea Dood View Post
    That will not work; the ports and cylinder arrangement on the late motors are tuned to the later MPEM's. At best, it won't run right. At worst, you will blow it up in a short amount of time.
    I am actually going the other way. I would be using a newer MPEM with an older Motor. Can these settings be changed on the MPEM or do I really need to get the old MPEM?

  8. #8
    Mtuned's Avatar
    Join Date
    Aug 2010
    Location
    Orlando FL
    Posts
    724
    The older motor is the problem child...

    IMO, you would be better off just getting a 02 motor, or rebuilding your old one!

  9. #9
    JohnCiccarelli's Avatar
    Join Date
    Oct 2008
    Location
    Bay Tree Lakes, NC
    Posts
    292
    Quote Originally Posted by Mtuned View Post
    The older motor is the problem child...

    IMO, you would be better off just getting a 02 motor, or rebuilding your old one!
    The original motor was not repairable. It spent a lot of time full of salt water and could not be taken apart.

    An 02 motor is not an option. I already have way too much invested in this ski.

  10. #10
    Quote Originally Posted by JohnCiccarelli View Post
    I am actually going the other way. I would be using a newer MPEM with an older Motor. Can these settings be changed on the MPEM or do I really need to get the old MPEM?
    Nope, fuel and ignition mappings are different, no way to reprogram. You need to pick up a 2000 or 2001 MPEM (preferably the 2001 as the maps are better...)

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 14
    Last Post: 06-13-2010, 06:21 PM
  2. 2002 GTX 4-tec in NC
    By NCRXP in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-18-2008, 08:53 AM
  3. is a 2002 gtx-di a good ski?
    By sic fish in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 09-04-2007, 08:44 PM
  4. 2002 GTX DI won't run above idle in water
    By zone 5 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-26-2007, 06:53 PM
  5. 2002 GTX DI MAintenece code?
    By Big Jay in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-10-2007, 08:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •