Results 1 to 2 of 2
  1. #1

    900 zxi temperature sensor/switch

    Ok, I've searched and read virtually every topic.

    On a 900 zxi can the temperature sensor/switch be bypassed for diagnostic purposes?

    It seems that when these fail, it results in a few similar symptoms.
    Loss of power
    Inability to exceed 4000 - 4500 rpm
    Stalling
    Plugs fouling
    Intermittent restored power

    Of all the threads on this topic, I could not find one that specified the temp switch/sensor was the culprit. Nor was any info of bypassing this sensor.
    It would appreciated if anyone could assist and elaborate on this a bit.


  2. #2

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 900 Zxi speedo doesn't work
    By Juscruzn in forum Kawasaki How To & FAQs
    Replies: 7
    Last Post: 07-05-2011, 08:12 PM
  2. 900 zxi stearing cable
    By grifter in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 05-19-2007, 10:56 AM
  3. 900 zxi help
    By axgrider73 in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 03-20-2007, 09:38 PM
  4. temperature sensors
    By brandn in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 12-18-2006, 05:25 PM
  5. Air Temperature Sensors on 03-04 EMS skis
    By Green Hulk in forum 4-Tec Performance
    Replies: 0
    Last Post: 10-31-2006, 03:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •