Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    1994 Polaris 750SLT Will not go to peak RPM

    When I hold the throtle open the RPMs do not peak. There seems to be something holding back the RPMs I have checked for pluged exhaust, it is OK. I have checked fuel, There seems to be a lot of gas coming from the fuel pump. I put in new spark plugs, The carbs look OK. What have I missed??

    Mikeywz


  2. #2
    I like Boobs. wetwolf's Avatar
    Join Date
    Nov 2005
    Location
    The NSA know's that I'm in Spokane, WA
    Posts
    804
    +1
    106
    You need to check the compression before you do anything else. How many RPM were you getting?

  3. #3
    I just put in new rings and the compression is 140 in each cylinder, I don't know how many RPMs guage doesn't work very well.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    If your tach isn't working, how do you know you're not reaching max RPM?

    What impeller is installed?

    Are the pump bearings good?

    Are you sure it's running on all 3 cyls?

  5. #5
    ThrottleOut's Avatar
    Join Date
    Aug 2011
    Location
    Corning, NY
    Posts
    727
    +1
    29
    Have you run through the standard fuji fuel system upgrades/maintenance (Rebuild carbs, triple output pump, fuel lines including those in-tank and fuel select valve)?

  6. #6
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    In or out of the water? You will easily hit the rev limiter on the CDI if you hit the throttle out of the water. Makes the motor sound like it is being held back.......

  7. #7
    The fuel pump has crossed my mind, what is the triple output pump?

  8. #8
    This makes more sence than any other suggestion, I have not had it in the water.

  9. #9
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by Mikeywz View Post
    I have not had it in the water.
    If it sounds like something is holding it back, my money is on the rev limiter. Ideal operating RPM in the water is 6250 rpm with idle at 1250 rpm. With the ski idling at 1250 in the water, it will idle in the high 2k rpm range out of the water because there is no load on the motor. It only takes a second of WOT to get into the 6k range, which i believe hits the rev limiter in the mid to high 6k range.... I thought there was something wrong with mine also when I first got it running out of the water.....Need to check RPMs....

    If you don't have the triple outlet, definately get it along with all the other fuel system upgrades..... http://www.google.com/products/catal...0044992484170#

  10. #10
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by Mikeywz View Post
    I just put in new rings and the compression is 140 in each cylinder, I don't know how many RPMs guage doesn't work very well.
    If by "doesn't work very well" you mean hard to read because it is faded, there is a fix in one of the threads here if you are not afraid to cut open you MFD and are handy with a dremel type tool.........

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 10-01-2012, 02:44 PM
  2. Polaris 2001 Virage TXI 1200 idles great will not go over idle
    By jsmiech in forum Polaris Open Discussion
    Replies: 5
    Last Post: 01-01-2012, 01:00 PM
  3. !996 polaris slx will not go full throtle in the water
    By clint rogers in forum Polaris How To & FAQs
    Replies: 19
    Last Post: 07-30-2010, 05:06 PM
  4. MSX 150 Will Not go over 2900 RPMS
    By rtburns in forum MSX/Matrix
    Replies: 3
    Last Post: 07-01-2009, 10:47 PM
  5. Polaris SLT 780 not getting to full rpms
    By motox1027 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-26-2009, 11:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •