Results 1 to 2 of 2
  1. #1

    Join Date
    Jul 2011
    Location
    Tampa Bay, FL
    Posts
    51

    help please dash

    03 gtx supercharged. Took to a shop to get supercharger re done. Got home and tried starting it to see how it sounded. Runs fine but my info center and gauges don't work. Almost like something is unplugged. Its dark now so I want to get a list together of some possible things to see if its something stupid that I can do because the shop is two hours away
    thanks so much


  2. #2
    Every adventure comes to an end........ Not Today! wreckingball's Avatar
    Join Date
    Sep 2009
    Location
    San Diego, California, United States
    Posts
    1,347
    +1
    2
    That's bizarre? Get a light too look inside and verify all your connectors are plugged in. There is nothing a shop would have touched in getting access to the SC that is electrical.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need HELP Please!
    By GeoRXT in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-30-2006, 08:04 AM
  2. HEy Guys Need Help PLEASE!!!
    By SpeedStang95 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-06-2006, 01:29 AM
  3. RXT 2005 Loose Hose - HELP PLEASE
    By BrAinZ in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-12-2006, 12:28 PM
  4. Can some one Post! A little Help Please!
    By Angelse68cal in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-04-2005, 07:57 PM
  5. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •