Results 1 to 2 of 2
  1. #1

    Join Date
    Jul 2011
    Tampa Bay, FL

    help please dash

    03 gtx supercharged. Took to a shop to get supercharger re done. Got home and tried starting it to see how it sounded. Runs fine but my info center and gauges don't work. Almost like something is unplugged. Its dark now so I want to get a list together of some possible things to see if its something stupid that I can do because the shop is two hours away
    thanks so much

  2. #2
    Every adventure comes to an end........ Not Today! wreckingball's Avatar
    Join Date
    Sep 2009
    San Diego, California, United States
    That's bizarre? Get a light too look inside and verify all your connectors are plugged in. There is nothing a shop would have touched in getting access to the SC that is electrical.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Looking for a used MoTeC dash
    By RUSH. in forum Yamaha ECU Support
    Replies: 14
    Last Post: 04-06-2010, 01:32 PM
  2. dash
    By snave in forum Polaris Open Discussion
    Replies: 3
    Last Post: 10-29-2008, 11:56 PM
  3. New Dash In
    By Neal Van in forum Polaris Open Discussion
    Replies: 2
    Last Post: 04-10-2008, 10:16 PM
  4. Custom Dash
    By SantaCruz163 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 11-01-2007, 12:22 AM
  5. 06 dash on 04??
    By BOOSTED in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-27-2007, 11:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts