Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    JLewis's Avatar
    Join Date
    Apr 2007
    Location
    titusville
    Posts
    346

    bad day for me! X charger isnt happy...

    not sure what's the main cause of the failure but riding back to the ramp yesterday, i started to notice the pitch change of the wine from my SC as it's very noticeable with the rear air. then a few minutes it really made some crazy noises!! i killed the engine immediately and had my buddy pull me in.
    oil on the dipstick is clean but am still scared of what can make it into the oil from it. might have to pull this motor out to make sure.... cant win!Click image for larger version. 

Name:	IMG_3626.jpg 
Views:	64 
Size:	51.5 KB 
ID:	259479Click image for larger version. 

Name:	IMG_3625.jpg 
Views:	85 
Size:	61.2 KB 
ID:	259480


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Bearing let go????

  3. #3
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    damn never seen a gear grounded like that, hopefully no one left any tools near the rear air and got jammed in the impeller

  4. #4
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Can you pull the front cover to see what the impeller looks like??

  5. #5
    JLewis's Avatar
    Join Date
    Apr 2007
    Location
    titusville
    Posts
    346
    fixin to pull it apart now. it's been doing perfect all year long. just strange why it would just now do it.

  6. #6
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Thats when shit happens brotha,when you least expect it...

  7. #7
    JLewis's Avatar
    Join Date
    Apr 2007
    Location
    titusville
    Posts
    346
    guess that increased pitch was the metal to metal! i think its time for one of those ET137 wheels i've been hearing about!Click image for larger version. 

Name:	IMG_3627.jpg 
Views:	52 
Size:	46.6 KB 
ID:	259481

  8. #8
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,691
    +1
    40
    You have a bearing failure!I had the same problem in a customers ski 2 years ago.

  9. #9
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Looks like youll need a rebuild kit also....I think i would pull the PTO cover too and check the flywheel and also look for metal pieces seeing the gear is chewed and broken up some...

  10. #10
    JLewis's Avatar
    Join Date
    Apr 2007
    Location
    titusville
    Posts
    346
    good idea, fixing to pull her apart now. this wasnt on my to do list for today! change of plans now...

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 08-31-2010, 07:31 PM
  2. BAD DAY for one FZ owner (not me)
    By flkeyzgp1300r in forum Yamaha PWC Performance (4-stroke)
    Replies: 12
    Last Post: 08-09-2010, 08:27 PM
  3. Sad day for me!!!
    By Rodneyae in forum Open Discussion
    Replies: 7
    Last Post: 04-22-2008, 01:07 AM
  4. Sad day for me.
    By DarthAWM in forum Open Discussion
    Replies: 19
    Last Post: 04-18-2008, 07:21 PM
  5. Big day for me Saturday!
    By Pistonwash in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 12-19-2006, 01:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •