Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    Join Date
    Apr 2011
    Location
    New Zealand
    Posts
    25

    05 rxp beeps at me all the time

    Hi all,

    Have an 05 rxp, its going great, new washers, wear ring and "adjusted" impeller. The only issue i have is when giving it a fist full on hard turns it beeps at me. Any idea what this is?

    Thanks.


  2. #2
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Is it throwing a code or going into limp mode? How's the oil level?

  3. #3

    Join Date
    Apr 2011
    Location
    New Zealand
    Posts
    25
    How do i check error code? Doesn't seem to go into limp mode or loose power as soon as im out of the hard turn/doughnut im back to kicking along at 65ish with no beeps or errors. I'll re-check oil level but this was first ride after a dealer service so should be perfect unless its sucking it. Ski has done 50 hours and otherwise doesn't seem to have any issues. All services up to date including supercharger rebuilt at 50 hours.

  4. #4
    There is one sensor that will cause phantom codes and beeps without an internal record; the exhaust temp sensor on the waterbox. If it loses connection on hard turns, it will beep and throw a code, but this sensor doesn't store codes like many others, it just goes away until it gets triggered again. Most other sensors throw a stored fault in this type of scenario.

  5. #5
    HardmanGT's Avatar
    Join Date
    Aug 2009
    Location
    Rutherfordton, NC
    Posts
    459
    +1
    3
    Quote Originally Posted by NZ_Dave View Post
    I'll re-check oil level but this was first ride after a dealer service so should be perfect
    This alone leads me to believe your oil level is low. The oil level should be between the bends on the dipstick. Easy to check, easy to fix if so.

  6. #6

    Join Date
    Apr 2011
    Location
    New Zealand
    Posts
    25
    I will check/re-check the oil tonight. How warm does the ski need to be to give an accurate level on the stick? I was not low on oil pre service and did it now its had a service and stil does it..
    Would you reccomend pulling out the water box sensor to give it a clean up/check connection?

  7. #7

    Join Date
    Apr 2011
    Location
    New Zealand
    Posts
    25
    Checked oil level all ok (between marks when cold). Pressed set 5 times and no faults codes present. I'll take it for a run again this weekend and see what happens.

  8. #8
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    As Sea Dood said the water box overheat is your most likely cause. Many open up the three holes in the J-Pipe that feed the waterbox.

  9. #9

    Join Date
    Apr 2011
    Location
    New Zealand
    Posts
    25
    ok thanks, will this cause damage? Is it likely to be to hot or a dodgey sensor. I'll have a google around for links to enlarge holes.

  10. #10
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    My guess is you are temporarily running hot. The three hole are under the j-pipe coupler they are around 1/8" and we open the to 3/16-1/4"

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yamaha GP1200 running at 3-4k rpms all the time
    By Aaron1991 in forum Yamaha PWC Performance (2-stroke)
    Replies: 16
    Last Post: 05-03-2012, 07:12 PM
  2. Replies: 6
    Last Post: 04-02-2012, 08:45 PM
  3. Why does the DSS have to beep all the time??
    By dgiles in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 07-16-2008, 09:57 AM
  4. WTB a 05 RXP but scared of all the SC horror stories
    By Masterz in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-17-2008, 06:42 PM
  5. RXP beeps at me!
    By Newcastle in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-02-2007, 12:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •