Results 1 to 3 of 3
  1. #1

    Genesis battery mount problem

    I purchased a genesis Fitch 1200 the previous owner did not use stainless bolts on the battery mounts and one of the bolts corroded into the nut secured in the fiberglass hull. The bolt broke off leaving a portion still in the nut. I tried to drill it out and extract it, but the nut came off of the fiberglass and now I have no way to secure the battery and EMM, any ideas?


  2. #2
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    I would just get some new nuts and epoxy them into the hull. SHould be able to go to your local automotive store or hardware store and find something that will work. Cheers

  3. #3
    I used the epoxy method and so far so good, thanks for the advice

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 1200 genesis start stop problems
    By steelehead in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-30-2008, 07:03 PM
  2. 2001 genesis i heating problems
    By bruddahdave in forum Polaris Open Discussion
    Replies: 9
    Last Post: 03-08-2008, 08:47 PM
  3. Battery charging problem...help
    By paperbirch in forum Polaris Open Discussion
    Replies: 13
    Last Post: 12-08-2007, 01:28 AM
  4. 96 slx 780 motor mount problem
    By wsony13 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 07-11-2007, 01:14 AM
  5. Genesis FFI Oil Problem- Please help
    By jmason2088 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 11-08-2006, 01:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •