Results 1 to 4 of 4
  1. #1
    rxpdz's Avatar
    Join Date
    Jul 2009
    Location
    Europe Poland Warsaw
    Posts
    118

    MSX 110 will not start - HELP

    Hi,
    Guys I need an input from You in solving my case,
    I bought a MSX some time ago , which I thought was a great deal- Now I now it wasnt
    The ski was complete except for the engine which was in pieces like a jigsaw.
    I got the engine in a big box.
    The nikasil went of ( probable over heating) and the rest of the engine looked like a disaster, the previous owner before never took care it, and he used to ride in really salt water.
    So I bought it , and starteed to solve the puzzle.
    I had to buy a dozen of new parts, managed that after a while, sleeved the cylinders etc.
    ( I rebuild BRP engines for years and build 4tec engines for racing, so mechanically everything ,in my opinion, is OK)


    I dropped the engine in, plugged everything together , filled with Oil ( according to what I read here about overfilling)

    Did not fill with cooling lubricant YET



    And Now

    I started the motor and I looked like running fine for 15-30 seconds (hard to say),

    After that time the motor just when off,died

    My fist thought was that it was out of fuel as the tank was quite empty, so I run out bought 10 liters of fuel,filled it up

    Tried to start it again an NOTHING,



    - When the engine was stopping it looked like the ECU just cut it of,

    - the motor turns with no issue, did not check compression Yet

    - The Check engine blinks after about 2 seconds when I try to start it,

    - It has spark ( but don't know for how long)

    - the injectors spray fuel ( but don't know for how long)

    - The battery is New



    Is it possible that one of the sensors is Bad and the ECU gets a message not to start after it powers up?

    When I push start it looks like the motor what's to start but something is electronically blocking it,

    I didn't check for how long the spark goes on are for how long does the fuel spray.



    Any suggestions will be helpful.
    I will check the compression tomorrow ( as it night here- I live in Poland Europe),
    I will also check if the spark and injector spraying are constant.


    tHANKS
    Pete


  2. #2
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    You have spark and fuel sounds like it shold be running to me.
    Have you the fuel supply and return lines the right way round?
    Cheers

  3. #3
    rxpdz's Avatar
    Join Date
    Jul 2009
    Location
    Europe Poland Warsaw
    Posts
    118
    Nop, the fuel lines seem to be ok, I will have a diagnostic tool in a few days so I will know why is the red check blinking.
    Is the fuel signal read from the same sensor as the ignition if any body knows- looks like i lost timing

  4. #4
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    Quote Originally Posted by rxpdz View Post
    Nop, the fuel lines seem to be ok, I will have a diagnostic tool in a few days so I will know why is the red check blinking.
    Is the fuel signal read from the same sensor as the ignition if any body knows- looks like i lost timing
    Injectors and ignition use camshaft position sensor and crankshaft position sensor.
    Red light blinks 10 times on start up, then if no problems goes out.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Msx 110 will not stop running
    By keskinner23 in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 08-26-2012, 09:56 PM
  2. Sn SJ will not start. HELP
    By magic74 in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 02-04-2010, 08:03 AM
  3. MSX 150 Will not start on angle
    By rcsscraig in forum MSX/Matrix
    Replies: 11
    Last Post: 07-28-2009, 11:23 AM
  4. my ski will not start- help
    By winston262262 in forum 4-Tec Performance
    Replies: 14
    Last Post: 09-04-2008, 05:51 PM
  5. will not start HELP
    By Neal Van in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-01-2007, 07:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •