Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    R&D Plate installed 300X, speed incorrect now.

    I just installed the Riva Scom, Wastegate Block off and R&D Plate and all worked almost perfect. Pulled away a lttle from another 300X with just SCOM. The problem now is that the speed is incorrect, really low. When I´m doing 70 MPH it reads 45. The other 300X was doing 68 and I was pulling away slowly. I checked the cables on the plate and hey are fine, the only thing I noticed is that the sensor/wheel (don´t know what to call it) is not flush with the plate.

    I will check again tonight and reinstall it but has anyone had this problem?


  2. #2
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    Yes it is in the design of the plate. The water does not flow through the wheel properly any more. Quite often I was reading 0 mph.
    You are not having any problems out of the ordinary.

  3. #3
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Plus the speedo stock is not really accurate anyways get a gps

  4. #4
    TEAM BRONX TECH FAT BOY's Avatar
    Join Date
    Mar 2009
    Location
    Bronx, NY
    Posts
    353
    The stock speedo is just a dream meter. When you pull up to the line, tell your opponent you have a fast one. 45mph. Good conversation piece.

  5. #5
    Can it be fixed? Maybe a little trimmer on the plate to make the wheel go a little lower?

  6. #6
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    It's all ready going slower because it's not on the water as much. Only way to fix it is put stock plate back on

  7. #7
    The stock speedo wheel is VERY accurate on the 300. I've checked 3 different machines against gps and they were all within 1-1.5 mph of actual speed. No Dream-o-meter on these skis.

  8. #8
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    now your dreaming, its not often i ride on glass and it only reads to 108kmh so how do you read your speed above this? doenst change the fact that anything reading off a paddle is going to be classed as a dream o meter

  9. #9
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Quote Originally Posted by Chris288 View Post
    The stock speedo wheel is VERY accurate on the 300. I've checked 3 different machines against gps and they were all within 1-1.5 mph of actual speed. No Dream-o-meter on these skis.
    Mines accurate as well.



    At idle. Lmao.

  10. #10
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    Mine WAS also. I was very surprised.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to improve speed accuracy after R&D Ride Plate installed on 2012 Ultra 300X?
    By Vincent in forum Kawasaki PWC Performance (4-stroke)
    Replies: 51
    Last Post: 07-30-2012, 04:35 AM
  2. Is this ride plate costing me speed????
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-25-2006, 06:35 AM
  3. D-Plate Install
    By Chrisrokc in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 06-19-2006, 09:48 PM
  4. R&D D-PLATE INSTALLATION INSTRUCTIONS.
    By CrazyA in forum Yamaha How To & FAQs
    Replies: 4
    Last Post: 01-22-2006, 06:01 AM
  5. IC Block off plate - install help??
    By Vern in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-02-2005, 10:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •