Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18

Thread: CDI Testing

  1. #1
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140

    CDI Testing

    I have several CDI boxes from 94, 95 750s and a 96 780 that I have managed to collect over the last few months. I would like to test them. I do have a running ski to test them on. Are CDI boxes either go or no go? Can I hook one up and assume if the engine fires and will rev (throttle blip) briefly out of the water that the box is good? Do CDIs fail all at once or do certain aspects of them go?

    Thanks for all the continued help!!!


  2. #2
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    They normally just fail,I had one that had been recurved that ran but acted up,But that was a reprogramming that didn't take right. If you plug them in and they run,....normally good. But once one gets heat soak,I guess you could see a problem possible.

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Quote Originally Posted by Keddano View Post
    They normally just fail,I had one that had been recurved that ran but acted up,But that was a reprogramming that didn't take right. If you plug them in and they run,....normally good. But once one gets heat soak,I guess you could see a problem possible.
    Yep ^^^^^^^^


    Normally bad Fuji CDI's wont spark.

  4. #4
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Perfect - Thanks!

  5. #5
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    While testing CDIs, I forgot to insert my lanyard key and thought the first one was bad. Thing is, one of the cylinders would occasionally fire every 10 or so revolutions like it just needed a little more fuel........ Once I put the key in, started and idled great. Is this normal or a sign of some kind of trouble??

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    You get intermittant spark when the lanyard is not installed.

    Normal

  7. #7
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Sweet. Thanks!

  8. #8
    Did you ever figure out if heat soaking would cause a cdi to fail. My ski is shutting down hot and won't refire until it cools I'm thinking cdi or coil but don't want to start parts changing blindly

  9. #9
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Quote Originally Posted by jwick View Post
    Did you ever figure out if heat soaking would cause a cdi to fail. My ski is shutting down hot and won't refire until it cools I'm thinking cdi or coil but don't want to start parts changing blindly

    More likely a stator

  10. #10
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by BryanP View Post
    More likely a stator
    +1 You can check the tolerances on the stator by testing with a multimeter. Start there and compare to original specs.....

    http://www.greenhulk.net/forums/showthread.php?t=98103

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need my CDI tested--Genesis 1999
    By CJC in forum Polaris Tech Tips and Info
    Replies: 3
    Last Post: 07-28-2015, 11:31 AM
  2. Coil/cdi testing
    By Jessie00721 in forum 2-Stroke Performance
    Replies: 14
    Last Post: 07-09-2015, 06:06 AM
  3. CDI Testing taking place
    By BlueFishCrisis in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-26-2013, 04:59 PM
  4. CDI testing 1996 SL 700
    By Luckyme in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 08-26-2010, 09:08 PM
  5. slt 750 1995 cdi test
    By sinclair in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-24-2008, 09:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •