Results 1 to 6 of 6
  1. #1
    ricky86's Avatar
    Join Date
    Jun 2011
    Location
    the netherlands
    Posts
    302
    +1
    19

    is this normal???

    hi,

    i'm rebuilding my rxp motor and i noted that the inside of the magneto flywheel are a few dents from the front to the back side of the magneto flywheel. is this normal????

    thanks

    Click image for larger version. 

Name:	DSC00106.jpg 
Views:	83 
Size:	80.5 KB 
ID:	260343


  2. #2
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Quote Originally Posted by ricky86 View Post
    hi,

    i'm rebuilding my rxp motor and i noted that the inside of the magneto flywheel are a few dents from the front to the back side of the magneto flywheel. is this normal????

    thanks

    Click image for larger version. 

Name:	DSC00106.jpg 
Views:	83 
Size:	80.5 KB 
ID:	260343
    Yes. But others will chime in also to reassure my answer. Good luck on the rebuild. I recommend purchasing new Flywheel bolts and head bolts since they are stretch bolts if you haven't.

  3. #3
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,691
    +1
    40
    Quote Originally Posted by ADAMBOMB View Post
    Yes. But others will chime in also to reassure my answer. Good luck on the rebuild. I recommend purchasing new Flywheel bolts and head bolts since they are stretch bolts if you haven't.
    +1 to all!
    I have two flywheels removed from running skis and they are exactly the same.IMO you have to purchase new oil pumps and do the 08 oiler mod for the S/C also!

  4. #4
    ricky86's Avatar
    Join Date
    Jun 2011
    Location
    the netherlands
    Posts
    302
    +1
    19
    oke thank for the info. i have new oil pumps, 08 oil mod and new bolts. in a few weeks i'll start a build tread on my new RXP for cc - racing

    thanks again

  5. #5
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Quote Originally Posted by ricky86 View Post
    oke thank for the info. i have new oil pumps, 08 oil mod and new bolts. in a few weeks i'll start a build tread on my new RXP for cc - racing

    thanks again
    Awesome. Whats the reason for the rebuild? How many hours on the ski?

  6. #6
    ricky86's Avatar
    Join Date
    Jun 2011
    Location
    the netherlands
    Posts
    302
    +1
    19
    the camshaft chain snapped and broke a rockerarm and one tooth off the crankshaft. i bought it this way for a low price

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is this normal???
    By Full_Throttle in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 03-11-2008, 12:57 AM
  2. is this normal?
    By 07vette in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-04-2007, 12:08 AM
  3. Is this normal?!?!
    By Titanese in forum 4-Tec Performance
    Replies: 21
    Last Post: 06-30-2007, 07:43 AM
  4. Is this normal?
    By WildBill9000 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-10-2006, 03:36 PM
  5. Is this normal???? Plug not connected....?
    By GeoRXT in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-29-2006, 09:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •