Results 1 to 8 of 8
  1. #1
    Electronics Guru Alpheus's Avatar
    Join Date
    Aug 2010
    Location
    Lake Anna Va
    Posts
    520
    +1
    1

    Accelerator Pump Injector Question

    I just rebuilt my Carbs for 2000 XPL 951 46mm BNI. I performed all of the tests per the manual with my hand pump and everything is in spec accept for the injector test.



    According to this they are supposed to open at 13psi. Mine are open all the time and hold no pressure. They do however hold a vacuum, so the check valve is working. I checked another set of identical carbs and they did the same thing. Are these injectors serviceable or replaceable???
    Last edited by Alpheus; 12-27-2011 at 03:08 PM.


  2. #2
    Electronics Guru Alpheus's Avatar
    Join Date
    Aug 2010
    Location
    Lake Anna Va
    Posts
    520
    +1
    1
    Come on. This forum has a collection of the greatest minds in this sport and no one can give me an opinion on this? Someone at least give me a BS answer. Thanks...

  3. #3
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    878
    +1
    11
    The manual says 2.8 psi plus or minus .6 psi.......... ???? You are probably reading kpa ?? It is 19.4kPa plus or minus 4.7 kPa

  4. #4
    Electronics Guru Alpheus's Avatar
    Join Date
    Aug 2010
    Location
    Lake Anna Va
    Posts
    520
    +1
    1
    I took the pic above right out of the Seadoo manual and it states 13 psi +or- 3 psi. What manual do you have that contradicts that info? It did seam a little high to me because the pressure the accelerator pump puts out is no where near 13psi...

  5. #5
    m schmidt's Avatar
    Join Date
    Mar 2007
    Location
    East, Tn.
    Posts
    235
    +1
    2
    This one is easy Get rid of the accelertor pump. And rejett the carbs. 951's need more fuel at cruise away. I never did like the way accelertor pump carbs hit.

  6. #6
    Electronics Guru Alpheus's Avatar
    Join Date
    Aug 2010
    Location
    Lake Anna Va
    Posts
    520
    +1
    1
    No, Ill keep the accelerator pump. Im not into flat out speed. I run on the Chesapeake Bay and like the low-end for jumping waves. Ill run it the way it is and watch watch for leaking injectors while its running with the borescope.

    Am I the only one that's ever done this test on the accelerator pump injectors? Or do I own the only set of carbs that are failing???

  7. #7
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    878
    +1
    11
    Quote Originally Posted by Alpheus View Post
    I took the pic above right out of the Seadoo manual and it states 13 psi +or- 3 psi. What manual do you have that contradicts that info? It did seam a little high to me because the pressure the accelerator pump puts out is no where near 13psi...
    Been on Vacation here you go.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	img051.jpg 
Views:	118 
Size:	58.4 KB 
ID:	261545   Click image for larger version. 

Name:	img052.jpg 
Views:	84 
Size:	57.4 KB 
ID:	261546  

  8. #8
    Electronics Guru Alpheus's Avatar
    Join Date
    Aug 2010
    Location
    Lake Anna Va
    Posts
    520
    +1
    1
    What year manual is that? The manual I have is for a 99 XPL. That is where the above pic of mine came from. Must be a typo in my manual. Weird. But in any case I like yours better because my carbs pass that test with flying colors. Thanks...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Accelerator Pump bypass question
    By jc1153 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-11-2012, 11:43 PM
  2. Accelerator Pump Removal Question
    By oldschool1921 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 09-16-2009, 02:24 PM
  3. accelerator pump and impellar question on gp1200r
    By spyder3000gtvr4 in forum Yamaha Open Discussion
    Replies: 8
    Last Post: 09-04-2008, 04:19 PM
  4. 2001 GTI 717 accelerator pump and carb question.
    By oneeyedjack in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-13-2008, 08:20 AM
  5. 40mm accelerator pump question
    By christian79 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 09-24-2007, 06:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •