Results 1 to 6 of 6
  1. #1

    Ultra 300X Pump and Impeller Warrantee

    I recently removed the pump from my 300x to check my bearings and seals and noticed a strange wear pattern on the wear ring,upon dissasembly I noticed deep gouges and some stainless shavings wedged between the impeller as I spun it.Closer inspection revealed that the area where the set screw is in the ring seemed to have all the contact and the screw was protruding thru the ring.This also caused deep scratching of the impeller blades as well as wear.and I also believe this is the vibration I have been feeling.Kawasaki did cover the Jet pump vane guide but will not cover the impeller.My thoughts are ,if this was a manufacturing defect.then they should cover the impeller as well.one more thing found was the end of the shaft where the nut goes on was gouged up as if it slipped when they were assembling it,so gouged that the nut could not be removed until the gouge was filed out and now the ends are all rounded off.
    Has anyone else noticed any of these issues? I hope to convince Kawasaki to send me a replacement Impeller. If anyone knows a number to call for something like this with Kawasaki I would greatly appreciate it.Thanks.Steve
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0014.jpg 
Views:	179 
Size:	58.1 KB 
ID:	260846   Click image for larger version. 

Name:	IMG_0009.jpg 
Views:	125 
Size:	40.1 KB 
ID:	260847   Click image for larger version. 

Name:	IMG_0015.jpg 
Views:	181 
Size:	46.8 KB 
ID:	260848   Click image for larger version. 

Name:	IMG_0016.jpg 
Views:	104 
Size:	47.8 KB 
ID:	260849   Click image for larger version. 

Name:	IMG_0013.jpg 
Views:	231 
Size:	56.1 KB 
ID:	260850   Click image for larger version. 

Name:	IMG_0008.jpg 
Views:	102 
Size:	50.8 KB 
ID:	260851  



  2. #2

    Join Date
    Feb 2006
    Location
    EAST COAST
    Posts
    1,168
    +1
    25
    Quote Originally Posted by ultralx07 View Post
    I recently removed the pump from my 300x to check my bearings and seals and noticed a strange wear pattern on the wear ring,upon dissasembly I noticed deep gouges and some stainless shavings wedged between the impeller as I spun it.Closer inspection revealed that the area where the set screw is in the ring seemed to have all the contact and the screw was protruding thru the ring.This also caused deep scratching of the impeller blades as well as wear.and I also believe this is the vibration I have been feeling.Kawasaki did cover the Jet pump vane guide but will not cover the impeller.My thoughts are ,if this was a manufacturing defect.then they should cover the impeller as well.one more thing found was the end of the shaft where the nut goes on was gouged up as if it slipped when they were assembling it,so gouged that the nut could not be removed until the gouge was filed out and now the ends are all rounded off.
    Has anyone else noticed any of these issues? I hope to convince Kawasaki to send me a replacement Impeller. If anyone knows a number to call for something like this with Kawasaki I would greatly appreciate it.Thanks.Steve
    Honestly the scratches on the impeller are pretty common,The manufactures are trying to get the impeller/vein clearances to a minimum for better pump performance.My Yamaha impeller looked just like yours and i also had scratched in the ring also..come to think of it my STXR did also.IMO I would think the impeller/nut situation would be a bigger concern.

  3. #3
    I know what you are saying.But its the Idea that they warranted the pump but not the impeller or shaft.Being that I am so careful to never beach or run anything thru my pump I should see no wear such as this impeller has.and the vibration is a concern of mine.
    Quote Originally Posted by jeff007 View Post
    Honestly the scratches on the impeller are pretty common,The manufactures are trying to get the impeller/vein clearances to a minimum for better pump performance.My Yamaha impeller looked just like yours and i also had scratched in the ring also..come to think of it my STXR did also.IMO I would think the impeller/nut situation would be a bigger concern.

  4. #4
    Impros.com...................... repair and weld and spin balance/ Better than new!

    125.00

    Dave

  5. #5
    That is very normal wear on the impeller...........you might as well learn to live with it.

    Dave.

  6. #6

    Join Date
    Aug 2011
    Location
    Australia Melbourne
    Posts
    839
    +1
    137
    Quote Originally Posted by sirbreaksalot View Post
    I think you were VERY lucky for them to warranty it as it is NORMAL wear marks

    I have the same mark on every ski I ride in salt water.............

    Waz

    Hi Sirbreaksalot,

    Although i have undertaken some work on my STX 15f I'm a bit paranoid when it comes to a high performance pump

    I want to remove inspect pump on 300x. Service manual states the need to use Red loctite 271 on some of the components. ie steering pivot bolts

    On my STX 15f I've only used Blue Loctite (although manual states Red)

    Would you follow Kawasaki instruction

    In-place of Molybdenum Disulide grease I have used Big Foot grease on spine, , what do you use?


    Thanks

    Ange

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 Ultra 150. Advice on pump and impeller please!
    By HydroStream6 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-28-2012, 10:06 AM
  2. WTB Pump and impeller, 97 SL1050
    By WFO in forum Polaris Classifieds
    Replies: 2
    Last Post: 04-09-2010, 01:32 PM
  3. WTB pump and impeller for 02 GTXDI
    By bankyf in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 07-19-2009, 12:54 PM
  4. What's the right position for pump and impeller washer for fx140
    By cuban133054 in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 04-25-2009, 12:50 PM
  5. WTB jet pump and impeller for 650sx
    By billy's gpr in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 09-03-2008, 07:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •