Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3

    Riva Stage 1 on a 06 RXP

    I installed the Stage 1 + the free flow exhaust last week and GPS'd at 69.5 MPH full & half tank. Also installed the metal SC washers. Oil is just below the full mark, wear ring is perfect and the Ski has 20 hours. I run on salt water in near perfect conditions. Best RPM has been 7840 far from the 8100 Riva claims. I did 68 stock at 7960 RPM before the mods.
    It definately acellerates stronger but I was expecting more top end. What advice can you guys give me?


  2. #2
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    First of all, welcome Antiguan RXP!

    Crawl under your ski, and look around.

    -Is the speedo hanging too low?
    -Did you fill in the bolt holes?
    -The RXP needs air. Do a run with the hood propped GENTLY open with a towel, and the bucket out, ON SMOOTH water, and see if the rpms go up.
    -Talk to Jerry about your prop.
    -Take the pump cone off.

  3. #3
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    what prop?
    sounds like a 15/20
    But then again, your stock rpms sound a bit low too.

  4. #4
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Throttle adjustment needs to be verified.

  5. #5
    mxl16's Avatar
    Join Date
    May 2005
    Location
    Central NJ
    Posts
    1,590
    one of the blades on the prop might be out of whack

  6. #6
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by hydrotoys View Post
    First of all, welcome Antiguan RXP!

    Crawl under your ski, and look around.

    -Is the speedo hanging too low?
    -Did you fill in the bolt holes?
    -The RXP needs air. Do a run with the hood propped GENTLY open with a towel, and the bucket out, ON SMOOTH water, and see if the rpms go up.
    -Talk to Jerry about your prop.
    -Take the pump cone off.

    Had the same problem after installing my stage 1..Like Mark said check all the above ...If all is good then you may need to have the prop tweeked..If you dont know how there is a how to in the tech section and if you still dont understand or feel comfortable tweeking the prop then I know Jerry does it for a small fee and does a awsume job..

    Scott

  7. #7
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3

    Riva Stage 1 on a 06 RXP

    I noticed that the trim is useless above neutral, speed drops off big time.
    The VTS was disasembled to install the free flow could the settings change ?
    Should the Reverse bucket mod help this problem?
    Do the ride plate holes really make a difference when filled?
    How does the impeller bearing survive without the nose-cone?
    I installed the finger throttle conversion and had to adjust the cable to ensure full throttle. Does the throttle body end limit suggest full open butterfly?
    Going to try opening up the hatch tommorow. Hope to see the 72 with this set-up...

  8. #8
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3

    Antiguan RXP

    The prop is 14/19R.

  9. #9
    mxl16's Avatar
    Join Date
    May 2005
    Location
    Central NJ
    Posts
    1,590
    Quote Originally Posted by Antiguan RXP View Post
    I noticed that the trim is useless above neutral, speed drops off big time.
    The VTS was disasembled to install the free flow could the settings change ?
    Should the Reverse bucket mod help this problem? not really but if u have a wedge its good to do.
    Do the ride plate holes really make a difference when filled? YES
    How does the impeller bearing survive without the nose-cone? no u are talking about the tail cone. the nose cone is the green cone on the impeller, its supposed to add speed and acceleration when taken off completely.
    I installed the finger throttle conversion and had to adjust the cable to ensure full throttle. Does the throttle body end limit suggest full open butterfly? take off the elbow that goes from the sc to the TB. open the TB full and stick ur head down there and make sure that the butterfly is perfectly straight when at full throttle. it could be opening more than it should which would create turbulance.
    Going to try opening up the hatch tommorow. Hope to see the 72 with this set-up...

  10. #10
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,627
    +1
    806
    i dont suggest you take the nose cone off your impeller since you run your ski in salt water.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Finally! 10 hrs on the 06 RXP
    By ou812 in forum 4-Tec Performance
    Replies: 35
    Last Post: 12-14-2006, 12:35 AM
  2. How Fast is 8100 RPM's On a '06 RXP
    By Flynfox in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 11-13-2006, 10:19 AM
  3. Well Boyz got new GPS results!! on the 06 RXP again!!!
    By NeverEndn in forum 4-Tec Performance
    Replies: 115
    Last Post: 07-26-2006, 11:10 AM
  4. My reg Stickers on my 06 rxp
    By ADAMBOMB in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 04-11-2006, 10:01 PM
  5. Dito on the 06 RXP
    By sleeplessnMS in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 04-08-2006, 08:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •