Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672

    Question Stupid Plug Question

    So I bought the 05 RXT and already threw an intake, pump wedge, grate and impeller in. I then went to replace the plugs and noticed the plug caps were not on and it looked like they were stuck up inside the coil. I destroyed the coil before figuring out the plug caps were removed.

    The question is how do I remove the top of the spark plug to expose the threaded stud? I tried and it twised the plug apart. I am using DCPR8E plugs


  2. #2
    mac_man_luke's Avatar
    Join Date
    Sep 2010
    Location
    South Australia
    Posts
    1,262
    +1
    22
    there are 2 versions of the plugs, one version has removable ends.

  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    There is two different stock numbers for the DCPR8E plugs one screws off the other does not.

    You want the NGK 4339 which has the removable tip. The 4179 doesn't and both are DCPR8E

  4. #4
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    thanks guys. I feel like an ass considering I built my aquatrax engine from the ground up and also built my SC'd V6 from the ground up and can't even replace a plug. Ooph

  5. #5
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by imp0ster View Post
    thanks guys. I feel like an ass considering I built my aquatrax engine from the ground up and also built my SC'd V6 from the ground up and can't even replace a plug. Ooph
    I thought the EXACT same thing many years ago when I first got my ski. I'm glad I didn't destroy a
    coil though . Lesson learnt.

  6. #6
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Quote Originally Posted by imp0ster View Post
    thanks guys. I feel like an ass considering I built my aquatrax engine from the ground up and also built my SC'd V6 from the ground up and can't even replace a plug. Ooph
    Yea, I wouldn't tell anyone else you did that Have you replaced your Supercharger washers?

  7. #7
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    I have not replaced the washers. I bought it with 30hrs on it 3 weeks ago and took it out once to test it after the purchase(FL and a wet suit ). Naturally it had bad gas in it so I puttered around for the first hour letting the seafoam break down the crap so it can pass through. I will rebuild my SC at 80 or 90 hours.

    I brought a GPS and had it to 63(old plugs and gas). Hit some chop and the stupid F'n fin on the side caught a wave and off I went. The people on shore told me my aerial acrobatics were awe inspiring. Really blows when the water catches the jacket at speed. I believe it's called the OPAS system. I will be cutting some aluminum and removing those as soon as I get my other goodies in.

    BTW I JUST sold my Exciter 220! Milled the heads down .010 and threw on the SBNs from the 270. Boat was a blast and I already miss it!

  8. #8

    Join Date
    Sep 2009
    Location
    n.j.
    Posts
    457
    welcome to the forum. Do NOT WAIT UNTIL 80hours to replace the stock ceramic washers. they are prone to failure and will cause alot more damage when they break. and the 04-05 bearings were a weak point also. so get it rebuild asap. do a search on here and you'll see why.

  9. #9

    Join Date
    Sep 2009
    Location
    n.j.
    Posts
    457
    Jerry, here on Greenhulk rebuilds them or you can opt for an x-charger but you'll want 42lb injectors to go with the x-charger

  10. #10
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    What kind of 42s? I have a spare set or FORD green meanies left over from my pre e85 days. Will those work? Are they high or low impedence?

    Honestly I don't know if I want to mess with the boost level of the engine. If someone can get me a compressor efficiency vs heat map, for stock 215 vs x type, that would be awesome. 70MPH and I'll be satisified.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Spark Plug Question?
    By enue in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 04-10-2007, 03:49 PM
  2. Stupid prop question
    By Lvnspeed in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 02-12-2007, 10:53 PM
  3. Stupid Prop Question
    By Lvnspeed in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 10-20-2006, 10:05 PM
  4. Stupid repitch Question
    By Snoman in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 07-24-2006, 09:36 AM
  5. Irridium Plug Question
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 33
    Last Post: 07-09-2006, 10:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •