Results 1 to 2 of 2
  1. #1

    Join Date
    Oct 2011
    Ontario Canada

    780 slt no start - fuel not getting into carbs

    this machine is new to me and when trying to start - - the fuel pump is pushing fuel to the carbs - a pulsing of fuel which i suspect is normal - but it will not fire - if i drop some fuel down the carbs it fires ! so is it a diapgram problem in the carbs ? im not even sure it has a diaphram , i suspect reeds but why am i not getting fuel to the carbs and running ? i need some assistance on the steps to take . please

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Sounds like the carbs have sat with stale gas/moisture in them for a while and gum and/or rust have formed. Open them up and take a look.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SLT 780 fuel troubles : Fuel Restrictor?
    By kegonsa in forum Polaris Open Discussion
    Replies: 12
    Last Post: 07-13-2011, 09:20 PM
  2. Ocean Pro 780 Carbs on my 96 SLT 780 and reed spacers
    By kegonsa in forum Polaris PWC Performance
    Replies: 21
    Last Post: 10-15-2010, 11:55 AM
  3. Another SLT 780 won't start
    By Fourbycor in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 05-27-2008, 10:47 PM
  4. 1996 SLT 780 start up..what to do??
    By paramuir in forum Polaris Open Discussion
    Replies: 31
    Last Post: 05-18-2008, 12:34 PM
  5. 93 SL 750 with SLT 780 carbs?
    By kabadou in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-02-2007, 06:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts