Results 1 to 5 of 5
  1. #1
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33

    No Fire, No Juice to MFD?

    Moving the engine from one ski to the other I carefully marked all the wires and put everything back to the original location,
    I put a fresh battery in and nothing,
    I can jump across the starter solenoid and the starter will turn over but that is it,
    I even tried putting the MFD in the stock ski and it works fine so no problem there,
    I really didn't want to start the ski yet, no gas and the exhaust valves are not hooked up yet, but I just wanted to turn it over,
    I checked the white button on the black box, opened everything up and no loose wires in there, fuses all good,
    any ideas?


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    i bet you mixed up the red cables the one that goes to the starter and the battery cable

  3. #3
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    Thanks,
    I am going to try that in the morning,

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Lanyard installed?

  5. #5
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    The red wires were reversed like lugs said,

    Put the short red wire on the starter and the long one on the battery and presto, we got fire,
    I hooked up the valve wires, put a little gas in the carbs and presto it fired right up,
    now for the other goodies to put on,

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 SL750 - No electrical juice to anything
    By pinchvalve in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-28-2010, 11:38 AM
  2. Polaris slth no power to MFD
    By rounder9 in forum Polaris Open Discussion
    Replies: 15
    Last Post: 03-08-2010, 01:40 PM
  3. No juice, where to start
    By rehr0001 in forum Yamaha How To & FAQs
    Replies: 3
    Last Post: 06-21-2008, 09:42 AM
  4. No reason to explain,just read this description...
    By WATER WOODY in forum Open Discussion
    Replies: 2
    Last Post: 08-29-2006, 06:21 PM
  5. no link to return to home page
    By wavehummer in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 04-21-2006, 07:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •