Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Rxp not revving out

    Just wondering What people's thoughts are with my 07 rxp ( 64 hrs ) not revving out revving to 6500 was fine last week (8100) is stock at the moment checked oil level is between the two bends prop and wear ring all good intake grate all clear etc the the only thing that had happened is a sensor warning came up on the dash display and the temp stopped workin could this have thrown a code to the ecu to stop it revving out cheers for any help


  2. #2
    HardmanGT's Avatar
    Join Date
    Aug 2009
    Location
    Rutherfordton, NC
    Posts
    459
    +1
    3
    Check to see if your hose from the super charger to the throttle body has blown off or is leaking. You are not getting boost most likely. If the hose is ok then check the slip on the super charger. Either the washers are slipping too much or they have failed.

    Use the search function to see how to check slip while in the ski. It's easy enough

  3. #3
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    +1 to the above.

  4. #4

    Join Date
    Mar 2006
    Posts
    1,829
    +1
    119
    spark plugs?

  5. #5
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    +2 to the above....

  6. #6
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Quote Originally Posted by Styler690 View Post
    Just wondering What people's thoughts are with my 07 rxp ( 64 hrs ) not revving out revving to 6500 was fine last week (8100) is stock at the moment checked oil level is between the two bends prop and wear ring all good intake grate all clear etc the the only thing that had happened is a sensor warning came up on the dash display and the temp stopped workin could this have thrown a code to the ecu to stop it revving out cheers for any help
    Since this is your second post. I will be the one to ask. Have you changed your supercharger washers? If not. Do not run the ski. Take the supercharger hose off and see if you can spin the charger wheel with your hand. If you can.. Then we will explain the rest. Good luck

  7. #7
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by Snoman View Post
    +2 to the above....
    Welcome to the forum!


    +3 too all the above

  8. #8
    ok ceramic sc washers did fail which i thought where replaced by previous owner or so he told me i have engine out in bits at the moment have ordered an complete x sc and 42 injectors and a few other go fast bits and pieces hoping to get it all back together next weekend

  9. #9
    HardmanGT's Avatar
    Join Date
    Aug 2009
    Location
    Rutherfordton, NC
    Posts
    459
    +1
    3
    Quote Originally Posted by Styler690 View Post
    ok ceramic sc washers did fail which i thought where replaced by previous owner or so he told me i have engine out in bits at the moment have ordered an complete x sc and 42 injectors and a few other go fast bits and pieces hoping to get it all back together next weekend
    Dude, you have soooo much more work to do. Do NOT just slam in a new super charger and call it a day. You need to get all the ceramic debris out of you engine before it takes out the oil pumps, bearings and timing chain! There are many many threads about people that have tried to do what you're attempting.

  10. #10
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Quote Originally Posted by HardmanGT View Post
    Dude, you have soooo much more work to do. Do NOT just slam in a new super charger and call it a day. You need to get all the ceramic debris out of you engine before it takes out the oil pumps, bearings and timing chain! There are many many threads about people that have tried to do what you're attempting.
    +1, you will finish destroying the engine if it isnt allready toast. Depends on how much riding you did after the RPMs dropped.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 24
    Last Post: 01-26-2012, 01:52 PM
  2. RXP Will Not Come Out the Hole
    By Overcenter76 in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-13-2010, 01:18 PM
  3. 04 RXP not running right
    By needforspeed04 in forum 4-Tec Performance
    Replies: 26
    Last Post: 03-21-2007, 06:58 PM
  4. Army RXP are ya out there Gary???
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 08-17-2006, 03:54 PM
  5. First time out with stage 1 05 RXP Not happy.
    By Fastcat in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-10-2005, 09:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •