Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 52
  1. #1
    JoeMomma's Avatar
    Join Date
    Apr 2011
    Location
    Tarpon Springs/Clearwater/Tampa Bay
    Posts
    61

    MY VXR is in the SHOP! She's not feeling too well.....

    So, I took my VXR out on the day after Christmas....Florida is a great place to live! I idled around for 5 min then took off at 3/4 throttle. About 2 min cruising in glass like conditions and 5 feet of water my VXR felt like it lost half of its power then started to want to veer to the right more than normal. I went to the nearest island flipped it on its side... nothing on the shaft, All blades on the prop were still there, and nothing visibly wrong. I took my seat off and noticed a little more water than normal in there, didn't think much about it. Took off again but this time it cavitated a little then hooked up. After about another 5 min of riding it still wanted to pull to the right and it didn't feel like " it was putting the power down ". RPM's were normal, no alrams, motor sounded normal, but speeds were way slower. Speedo was only hitting 30 Mph max....So i decided to go back to the ramp as I knew something wasn't right. I Backed my trailer in took the ski out of the water, opened the back plugs and water started to pour out full blast. I then took off the seat and holly shit water was almost half way up the motor. I then drained it out and tomorrow it's getting droped off for a diagnosis at my local Jet ski performance shop.

    question being Anyone have any ideas of what might be broken ?

    I got about 100 hours on my ski, bought it last feb. I have done all maintenance as suggested by the manual. I have never let it sit more than 2 weeks with out riding it. I do have the R&D power filter, Riva ribbon delete, and Riva Free flow exhaust. Mods have been on for about the last 3 months. Is there a possibility I blew some sort of seal or have some pump failure deal going on ?

    Either way it's under warranty and I will find out tomorrow whats wrong with it. Just wanted to throw it out there and see what you guys think. I will keep you posted once I find out.


  2. #2
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,563
    +1
    169
    wasnt there an issue with the intake grate supports pulling loose and leaking?

  3. #3
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    not good if it's pulling to the right and water filling the hull had a FZR pulling to one side a found the side of the pump tunnel blew out. Check your intake were it bolts in the front also. Hope that's not the case with yours hopefully only a lose hose clamp or a broken clamp.

  4. #4
    JoeMomma's Avatar
    Join Date
    Apr 2011
    Location
    Tarpon Springs/Clearwater/Tampa Bay
    Posts
    61
    Thanks for the quick reply! Just curious if a pump tunnel blew out, does that equal a new pump ? Think it could be related to my mods? Would an intake grate help or just make it worse? God I hope if If I have to take it to Yamaha I don't get shit for the mods...

    Thanks.

  5. #5
    Could it be leaking around the aftermarket exhaust? Did you put in the water when it was not running to try and see where the water could be leaking in from, or if it is accumulating when the engine is off?

    I hope it is any easy fix, good luck?

  6. #6
    JoeMomma's Avatar
    Join Date
    Apr 2011
    Location
    Tarpon Springs/Clearwater/Tampa Bay
    Posts
    61
    I'm pretty sure It wasn't related to the exhaust. Everything I looked at was on there nice and tight. I'm just glad I came back when I did other wise my ski would be at the bottom of the gulf of mexico! I think most of the water came in as it was sitting at the ramp when I went to go get my trailer. O well I will know by tomorrow!

  7. #7
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,134
    +1
    205
    Quote Originally Posted by JoeMomma View Post
    Thanks for the quick reply! Just curious if a pump tunnel blew out, does that equal a new pump ? Think it could be related to my mods? Would an intake grate help or just make it worse? God I hope if If I have to take it to Yamaha I don't get shit for the mods...

    Thanks.
    If your pump tunnel blew out, you'll prob need a new ski or a great repair shop.

    Before you get a new intake grate, diagnose the problem.

    I myself had an exhaust leak which was caused by my FF exhaust tearing at the stock outlet at 100 hours. Water would only leak in when the ski was shut off because when it was running, exhaust gas would essentially seal the leak.

  8. #8
    JoeMomma's Avatar
    Join Date
    Apr 2011
    Location
    Tarpon Springs/Clearwater/Tampa Bay
    Posts
    61
    AWESOME... well lets hope it's nothing major. I'll check out where my exhaust meets the stock outlet. THANKS MIKE!

  9. #9
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    sounds like it popped a hose somewhere in the hull, let us know what you find out what was wrong !!!!

  10. #10
    Ya, sounds like it has something to do with the Free Flow Exhaust system. One thing you can do in a situation like this is put the Ski on the trailer (tie her down real good) back the ski into the water and run it for a while on the trailer with the seat off. You should be able to see where the water is coming from. Glad you got back ok. Please let us know what the diagnosis is. JB

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. the new VXR/VXS with a turbo is in the works......
    By jetdave56 in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 01-31-2011, 05:21 PM
  2. Got my first mods in the mail today!
    By 05RXPnoob in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-30-2005, 06:54 AM
  3. Getting RXP back tomorrow after down time in the shop.
    By Jrsrxp in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-14-2005, 09:46 AM
  4. RXP still in the shop
    By Jrsrxp in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-10-2005, 09:52 AM
  5. My ski is at the fiber glass shop!!
    By MikeTrin in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-19-2005, 02:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •