Results 1 to 8 of 8
  1. #1

    99 xlt pump removal

    I am trying to remove the pump on my 99 xlt and it seems the driveshaft splines and intermediate shaft splines are stuck. I can pry pump from transom plate about one eighth of an inch and then pump will spring back. Any suggestions?


  2. #2
    HopatcongGPR's Avatar
    Join Date
    Feb 2006
    Location
    New Jersey
    Posts
    1,114
    Quote Originally Posted by hammerdog57 View Post
    I am trying to remove the pump on my 99 xlt and it seems the driveshaft splines and intermediate shaft splines are stuck. I can pry pump from transom plate about one eighth of an inch and then pump will spring back. Any suggestions?
    how many hours are on it..salt use?....the splines are probably frozen together. heat works best....but you have to be carefull not to damage the intermediate housing seals.....

    once you get it apart be sure to replace the rubber o rings in the intermediate shaft...you may have to replace more then that....but you wont know until you pull it down.

    i had to replace everythingon my 99 from the coupler back...salt is brutal! my boat had about 130 hours on it when i did that.

  3. #3
    Dirty Sanchez's Avatar
    Join Date
    Dec 2005
    Location
    Northern Virginia
    Posts
    1,038
    you got a fun one on your hands. If your lucky and have a slide hammer with 10 pound weight with the adapter arms you could bolt the slide hammer to the pump with bolts and washer and hammer/ pull away. Otherwise you'll be working on it for a while. I had one on gpr where the couple rotted out and and corroded on the mid shaft and wouldn't release the drive shaft. Once apart clean and lube all parts. Do a forum search also, may have some other idea's out there

  4. #4
    I had a guy tell me to clamp the coupler haves together and then try to pry pump loose. Has anyone done this? Any chance of damaging crank doing this? I dont want to have to pull engine if i dont have to.

  5. #5
    HopatcongGPR's Avatar
    Join Date
    Feb 2006
    Location
    New Jersey
    Posts
    1,114
    Quote Originally Posted by hammerdog57 View Post
    I had a guy tell me to clamp the coupler haves together and then try to pry pump loose. Has anyone done this? Any chance of damaging crank doing this? I dont want to have to pull engine if i dont have to.
    IF you do that... becareful with a hammer...the jolts from the hammer will get transfered to the crank bearings.

    use a torch to put some heat on the intermediate shaft....then give it a few shots with the slide hammer....or clamp the coupler and evenly pull the pump.

  6. #6
    MR. SCOVILLE UNIT SUCKMYWAKE's Avatar
    Join Date
    Aug 2005
    Location
    ASTON, PENNSYLVANIA
    Posts
    2,836
    +1
    8
    I Bet You Have A Bolt Left In There. Where Exactly Are You Taking It Off From? If You Are Pulling The Impeller Housing Off Too Dont Forget The Little 10mm Head Bolt To The Very Left Of The Pump. At Least This Is What The Gpr's Have.

  7. #7
    ....back from the dead.... J-ME's Avatar
    Join Date
    Aug 2005
    Location
    Delaware
    Posts
    1,577
    +1
    2
    Nope, seized splines.

    I was parting out a 99 XLL and had the same thing happen. Tried alot of different things including a sledge hammer. Wouldn't budge. 'ski was going to the dump anyhow, so I brought out the chain saw...cut the whole pump tunnel out! SMC is some tuff stuff.

    Obviously you don't want to do the above, so follow the suggestions of heat and a slide hammer.

  8. #8
    HopatcongGPR's Avatar
    Join Date
    Feb 2006
    Location
    New Jersey
    Posts
    1,114
    CHAIN SAW! I hope you video taped that! That could have been sued in some video clips....The Delaware Chain Saw Massacre!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GPR\XLT Carb Upgrade\ Accelerator pump removal
    By OsideBill in forum Yamaha How To & FAQs
    Replies: 278
    Last Post: 12-07-2017, 02:50 AM
  2. Starting xlt 1200 with jet pump removed?
    By ceayay in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 06-18-2016, 08:29 PM
  3. Yamaha xlt 1200 2001 acceleration pump removal
    By swaz311 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-06-2016, 06:53 PM
  4. WTB - Parts WANTED 99+ XL XLT Pump Shoe
    By Shibby1485 in forum Yamaha Classifieds
    Replies: 1
    Last Post: 12-25-2011, 09:50 PM
  5. WTB 99-04 GPR/XLT pump stator ASAP
    By roost5o in forum Yamaha Classifieds
    Replies: 16
    Last Post: 08-13-2008, 03:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •