Results 1 to 2 of 2
  1. #1

    Question '99 slx electric trim not working

    Does anyone know the easiest way to diagnose the electric trim not working on a '99 Polaris SLX 1050?

  2. #2
    Banned User
    Join Date
    Jun 2010
    Milwaukee WI
    unplug it and check for voltage coming out of the harness from the electrical box while operating the trim switch. You will have to hold down the bilge button to test this with the engine off. If you read voltage there, try connecting the motor directly to a 12v power source. It should operate. The other thing that can happen is that corrosion can freeze up the motor itself. Remove the plastic cover from the trim motor and see if its clean in there.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Adding Electric Trim
    By BlueFishCrisis in forum Polaris PWC Performance
    Replies: 23
    Last Post: 09-24-2011, 09:19 AM
  2. Electric Trim and Pump Wedge
    By ghostinstallations in forum Polaris PWC Performance
    Replies: 39
    Last Post: 09-13-2011, 07:14 AM
  3. Electric trim on 1996 slt780
    By Justin89 in forum Polaris PWC Performance
    Replies: 3
    Last Post: 09-07-2011, 06:17 PM
  4. mfd not working on 96 slx
    By cptn willigan in forum Polaris Open Discussion
    Replies: 7
    Last Post: 05-24-2010, 10:03 PM
  5. Electric Trim nozzles - What Polaris models benefit from them?
    By K447 in forum Polaris Open Discussion
    Replies: 21
    Last Post: 10-15-2007, 10:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts