Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    MiniChunks's Avatar
    Join Date
    Dec 2009
    Location
    Southington
    Posts
    166
    +1
    1

    anyone ever had the bracket for the SHO engine cover snap off?

    I was tinkering around with the ski today, and saw that one of the 4 brackets for the SHO engine cover had snapped off. I don't keep the cover on it at all so i really don't need all of them, but some are used for hangers. Has anyone removed the brackets and hung the wires off of other things? I found the broken half, but can only imagine that it would have damaged something eventually after bouncing around in there.


  2. #2
    SpeedJunky's Avatar
    Join Date
    Dec 2005
    Location
    Michigan
    Posts
    1,118
    +1
    35
    Happened to me on both my FZR's. Engine cover was off also. The vibration must be to much for them and they broke off. I was also glad I found them before the caused damage.

  3. #3
    MiniChunks's Avatar
    Join Date
    Dec 2009
    Location
    Southington
    Posts
    166
    +1
    1
    Quote Originally Posted by SpeedJunky View Post
    Happened to me on both my FZR's. Engine cover was off also. The vibration must be to much for them and they broke off. I was also glad I found them before the caused damage.
    did yours break above the bolt where the alignment pin is? that seems like it could be a weak point. Did you leave the non-broken ones on?

  4. #4
    mine broke also,take them off they are not needed.

  5. #5
    Kelly_A's Avatar
    Join Date
    Dec 2009
    Location
    Central Oklahoma
    Posts
    660
    +1
    17
    mine broke also,take them off they are not needed.

    Exactly - all 4 of mine have broken. I just pulled them and replaced the screws. On the left side of the engine, the mounting bosses are perfect for installing nylon "D" clamps for securing the breather hose w/ zip ties to keep it off the exhaust manifold


  6. #6
    MiniChunks's Avatar
    Join Date
    Dec 2009
    Location
    Southington
    Posts
    166
    +1
    1
    Quote Originally Posted by Kelly_A View Post
    mine broke also,take them off they are not needed.

    Exactly - all 4 of mine have broken. I just pulled them and replaced the screws. On the left side of the engine, the mounting bosses are perfect for installing nylon "D" clamps for securing the breather hose w/ zip ties to keep it off the exhaust manifold

    Great idea. Thanks!

  7. #7
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    I broke two of them when working on the ski. I removed the broken part and never did anything else. When I sell the ski I will replace them.

  8. #8
    08SHOC's Avatar
    Join Date
    Oct 2009
    Location
    Down Under
    Posts
    151
    +1
    5
    I wasn't even using the engine cover ...and noticed that 2 of the little supports had cracks straight through them . They fell apart when removing them .

  9. #9
    Neighborhood Superman SlowStang305's Avatar
    Join Date
    Jun 2008
    Location
    FL
    Posts
    1,324
    +1
    7
    Its a common thing for them to break when you do not use the engine cover.

  10. #10
    MiniChunks's Avatar
    Join Date
    Dec 2009
    Location
    Southington
    Posts
    166
    +1
    1
    Mine will be coming off this week. Don't want something I don't need causing any damage

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ANYONE ever use jb weld for minor fiberglass repair ? like for the hull?
    By noshowallgo in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 05-17-2013, 12:28 AM
  2. Has anyone ever polished the stator fins in an RXP??
    By skigolfnut in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-13-2011, 07:30 AM
  3. Anyone ever use the JetGladiator Rear bag/cooler
    By hawkrdr in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 06-01-2009, 03:44 PM
  4. No timing advance plate for the Sho engine?
    By christian gpr in forum Yamaha PWC Performance (4-stroke)
    Replies: 23
    Last Post: 12-11-2008, 07:03 PM
  5. Has anyone ever flipped the wedge upside down to help stop porposing?
    By gvnitup in forum Polaris Open Discussion
    Replies: 25
    Last Post: 06-10-2007, 09:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •