Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 50
  1. #1
    www.springbreak-florida.com rgard32's Avatar
    Join Date
    Dec 2006
    Location
    Saint Petersburg,Florida
    Posts
    665

    exhaust valves stopped working

    I got a book on this pro 785.. but just wanted to ask ...what is the most common thing to make the valves not open?? cable break?? ...it just stoppd in 1 second...no warning.....boat works fine otherwse...except rpm obviously..(around 6800)


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    check the vavle motor to make sure it's still working if you have a polaris manual it will give you the test procedure for it .if not i can copy it and post it for you .

  3. #3
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,134
    +1
    1,050
    Yes... check the servo motor.

  4. #4
    Rompe21's Avatar
    Join Date
    Jul 2006
    Location
    Tampa , Florida
    Posts
    717

    Thumbs down

    Quote Originally Posted by rgard32 View Post
    I got a book on this pro 785.. but just wanted to ask ...what is the most common thing to make the valves not open?? cable break?? ...it just stoppd in 1 second...no warning.....boat works fine otherwse...except rpm obviously..(around 6800)
    I tool polaris went out bank rup

  5. #5

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    HUH !!!!!!

  6. #6
    Quote Originally Posted by Rompe21 View Post
    I tool polaris went out bank rup

    Whhhhhaaaaaaaaaaaatttttttttttttttttttttttttttttttt

  7. #7
    www.springbreak-florida.com rgard32's Avatar
    Join Date
    Dec 2006
    Location
    Saint Petersburg,Florida
    Posts
    665
    yes i got a manual ..imma check it out tommorrow...i was just hopeing to hear something stupid simple to check an be a quickie fix lol..

    i will report back when i check it tommorrow..

    thanks again

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Quote Originally Posted by Rompe21 View Post
    I tool polaris went out bank rup
    Yes, of course! How did I not see that?

  9. #9

  10. #10
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Quote Originally Posted by Rompe21 View Post
    I tool polaris went out bank rup
    Thanks for setting us straight, I would have never come up with that answer. Silly, silly me.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gas Pressure Exhaust Valves
    By beerdart in forum Polaris PWC Performance
    Replies: 24
    Last Post: 06-28-2007, 08:05 PM
  2. Early Exhaust Valves
    By 785 lugs in forum Polaris PWC Performance
    Replies: 4
    Last Post: 04-26-2007, 10:38 PM
  3. digital display stopped working?
    By jeff007 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-24-2006, 06:52 AM
  4. Pro-Tec adjustable exhaust valve controller ?
    By Chezzy in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-04-2006, 02:21 PM
  5. exhaust valve
    By beachboy66 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-01-2006, 09:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •