Results 1 to 10 of 10
  1. #1
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9

    Question on R&D rideplate and 300x reverse bucket....

    For those that have the R&D rideplate....in order for the reverse to work properly are you finding that you have to shave or grind the bucket a bit where the bucket hits the rideplate in order for it to drop all the way down?
    From day one my "reverse" hasn't worked. Its almost like"neutral", as the ski goes nowhere in reverse.
    Last edited by lasportsmn; 01-10-2012 at 06:50 PM.


  2. #2
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,414
    +1
    76
    Quote Originally Posted by gmoeller View Post


    Imagine my horror when I realized what I had done.
    Good thing I own a Yamaha....
    I like the neutral when you put it in reverse... hahaha.
    If you want more reverse trust, trim up! I can't remember how much I did trim, but worked better!

  3. #3
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    Quote Originally Posted by gmoeller View Post
    OOPS! Oh boy...this is supposed to be in the Kawi section....NOW what do I do Moderators?
    Go easy on me boys!

    For those that have the R&D rideplate....in order for the reverse to work properly are you finding that you have to shave or grind the bucket a bit where the bucket hits the rideplate in order for it to drop all the way down?
    From day one my "reverse" hasn't worked. Its almost like"neutral", as the ski goes nowhere in reverse.
    I had this same problem with my 250X. There was a thread on the kawi side showing how and where to grind the bucket.

  4. #4
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    There are threads as stated that show you exactly where to trim.

  5. #5
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9

  6. #6
    Addicted Member 5001craig's Avatar
    Join Date
    Jul 2007
    Location
    Northeast Indiana
    Posts
    2,924
    +1
    11
    Either you're living right or lasportmn is just a great guy...

  7. #7
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    Quote Originally Posted by gmoeller View Post
    Good to hear, Sorry, I got side tracked when looking for it for you.

  8. #8
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    Quote Originally Posted by 5001craig View Post
    Either you're living right or lasportmn is just a great guy...
    I thought about leaving him to the wolves but I was feeling nice today.

  9. #9
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    Quote Originally Posted by lasportsmn View Post
    I thought about leaving him to the wolves but I was feeling nice today.
    I think 3 days was long enough...I had been tortured enough.

    I am forever indebted!


    As Gordon Lasiter put it, "just be glad you did not post a YAMAHA question on the Kawi thread". Talk about being thrown to the wolves...

  10. #10
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    OH yes we have been bored lately and just chomping at the bit. I have this done on both of my skis.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hull question on 2016 VX Cruiser HO and FX HO
    By Jcyz8788 in forum Yamaha Open Discussion
    Replies: 15
    Last Post: 07-20-2016, 12:56 PM
  2. Question on S/S wear rings and the 1/2 stainless ones
    By skigolfnut in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-24-2012, 06:35 AM
  3. question on throttle bodies at WOT and IDLE
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-13-2008, 12:00 PM
  4. Question on Intake Air Temp before and after Aftermarket IC
    By yellow4 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-01-2007, 12:20 AM
  5. newbie questions on trailer and ride plate
    By NJRXP in forum Sea Doo Open Discussion
    Replies: 27
    Last Post: 02-05-2007, 05:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •