Results 1 to 8 of 8
  1. #1
    SpectraBrite's Avatar
    Join Date
    Jul 2011
    Location
    Los Angeles, CA / Blythe, CA
    Posts
    255

    impeller for a 95 sl750 question

    will an impeller from a 92 - 94 sl 750 fit on a 95?


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    No in 94 they switched to a 148mm pump.

  3. #3
    SpectraBrite's Avatar
    Join Date
    Jul 2011
    Location
    Los Angeles, CA / Blythe, CA
    Posts
    255
    How much will a worn or slightly damaged impeller slow me down or hurt me.

    My 95 sl 750 that I picked up last season has a few small nicks and shows signs of wear.

    I was thinking about a new one or getting this one repaired.

  4. #4
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    My impeller has some good dings that I filed down. I can get a picture of it tonight and post it so you can see. I am seeing mid 40's GPS on my 94 SLT.......

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Damaged impellers will work. You just don't get maximum performance out of them.

    I would also think bearings can fail fater if it's not properly balanced though, so get it repaired or replaced IMO.

    There was no 750 in 1992. Just the 650

    Then in 93 they came out with the 750, but it used a 146mm jet pump. So the impeller is totally different VS. the 1994 and 95 750.

    In 1994 ALL polaris jet pumps used the 148mm big mouth modular type. Except for the Octane stand up.

  6. #6
    john zigler's Avatar
    Join Date
    Aug 2006
    Location
    WI
    Posts
    2,545
    +1
    33
    i believe i have some good, used 148mm 750 props here.

    send me an email or call the shop and remind me to take a look for you.

  7. #7
    SpectraBrite's Avatar
    Join Date
    Jul 2011
    Location
    Los Angeles, CA / Blythe, CA
    Posts
    255
    thanks, Im going to take a better look this eve at mine, After looking at the diagram it may be the stator that im talking about.

    I have never worked on a ski before this one.

  8. #8
    SpectraBrite's Avatar
    Join Date
    Jul 2011
    Location
    Los Angeles, CA / Blythe, CA
    Posts
    255
    nvm, it is the impeller. Now I will have to find a way to take a pic to see if it is a problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts Need stubby impeller shaft and pump stator for '95 SL750
    By SeaBee63 in forum Polaris Classifieds
    Replies: 4
    Last Post: 07-01-2014, 03:57 AM
  2. 95 SL750 Questions
    By Feral in forum Polaris Open Discussion
    Replies: 48
    Last Post: 06-20-2008, 10:48 PM
  3. Replies: 2
    Last Post: 05-16-2008, 11:27 PM
  4. 95 SL750 CDI question vs 96 SL780
    By TX21 in forum Polaris How To & FAQs
    Replies: 11
    Last Post: 09-21-2007, 02:06 PM
  5. 95 sl750 questions
    By 95 sl750 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 04-16-2007, 05:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •