Results 1 to 2 of 2
  1. #1

    polaris msx 140 pipe leak pleas help

    hi My jet ski is taking on water when the engine is turned on. I have ran it through the (this was at the front end off the engine) hose and have found that the pipe had a crack in it where it was about to be inserted . I have cut it off and re attached it. Once again I have put the hose to it and it looks like there is another small leak somewhere that i cant find. I know roughly where it could be but cant find any pipes around there.

    If anyone has any diagram off where the pipes are would you please be able to upload them to me please.

    Also what happens if I leave the hose running with the engine turned off. Does anything get filled up ??

    Thank you
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSCF0026.jpg 
Views:	80 
Size:	96.7 KB 
ID:	261640   Click image for larger version. 

Name:	DSCF0027.jpg 
Views:	56 
Size:	80.4 KB 
ID:	261641   Click image for larger version. 

Name:	DSCF0028.jpg 
Views:	102 
Size:	94.0 KB 
ID:	261642  
    Last edited by mitch04; 01-10-2012 at 09:09 PM. Reason: uploading some pictures.


  2. #2
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Never run the hose with the ski not running,Water can fill the cylinders thru the exhaust ports. Always start ski...turn water on....turn water off ....then shut off ski.

    There is 2 fittings on the front side of the stator cooling cover near the fuel tank on the 140,they let water help keep the stator cooler. If you had one cracked hose up there,they both may need replacing. Or the gasket between the cooling cover and stator cover may be leaking.
    Cooling Cover #28, Gasket #33, Fittings hoses attach to #30
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	9053b12.jpg 
Views:	142 
Size:	88.3 KB 
ID:	261643  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Overheated Polaris MSX 140 - Please help?
    By OzMSX140 in forum Polaris How To & FAQs
    Replies: 14
    Last Post: 10-04-2013, 11:16 PM
  2. need emm for 04 polaris msx 140 asap help please
    By steelbroke in forum MSX/Matrix
    Replies: 4
    Last Post: 08-17-2013, 08:56 AM
  3. 2003 polaris msx 140 ho injected ( HELP )
    By totalylitt in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-05-2013, 11:44 PM
  4. need help with polaris msx 140
    By Romaha in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-20-2012, 10:10 PM
  5. 2003 polaris MSX 140 problem - need help
    By orrjoe in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-25-2007, 01:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •