Results 1 to 2 of 2
  1. #1

    polaris msx 140 pipe leak pleas help

    hi My jet ski is taking on water when the engine is turned on. I have ran it through the (this was at the front end off the engine) hose and have found that the pipe had a crack in it where it was about to be inserted . I have cut it off and re attached it. Once again I have put the hose to it and it looks like there is another small leak somewhere that i cant find. I know roughly where it could be but cant find any pipes around there.

    If anyone has any diagram off where the pipes are would you please be able to upload them to me please.

    Also what happens if I leave the hose running with the engine turned off. Does anything get filled up ??

    Thank you
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSCF0026.jpg 
Views:	78 
Size:	96.7 KB 
ID:	261640   Click image for larger version. 

Name:	DSCF0027.jpg 
Views:	54 
Size:	80.4 KB 
ID:	261641   Click image for larger version. 

Name:	DSCF0028.jpg 
Views:	72 
Size:	94.0 KB 
ID:	261642  
    Last edited by mitch04; 01-10-2012 at 09:09 PM. Reason: uploading some pictures.

  2. #2
    Join Date
    Jul 2007
    Cedar Rapids,Iowa
    Never run the hose with the ski not running,Water can fill the cylinders thru the exhaust ports. Always start ski...turn water on....turn water off ....then shut off ski.

    There is 2 fittings on the front side of the stator cooling cover near the fuel tank on the 140,they let water help keep the stator cooler. If you had one cracked hose up there,they both may need replacing. Or the gasket between the cooling cover and stator cover may be leaking.
    Cooling Cover #28, Gasket #33, Fittings hoses attach to #30
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	9053b12.jpg 
Views:	138 
Size:	88.3 KB 
ID:	261643  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 Polaris MSX 140 HO
    By Steves MSX in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-04-2011, 08:46 PM
  2. Polaris MSX 140 ?
    By ftr0432 in forum MSX/Matrix
    Replies: 6
    Last Post: 05-03-2011, 07:40 PM
  3. Replies: 9
    Last Post: 07-16-2009, 05:06 PM
  4. WTB- MSX 140 Exhaust Pipe
    By SMOKEWAGON in forum Polaris Classifieds
    Replies: 2
    Last Post: 07-01-2009, 12:23 AM
  5. MSX 140 Exhaust Pipe Anybody?
    By SMOKEWAGON in forum MSX/Matrix
    Replies: 7
    Last Post: 06-30-2009, 01:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts