Results 1 to 9 of 9
  1. #1

    Polaris Slx1050 back firing

    Hi folks , new to site and needing help . I have a 1999 SLX1050 , I went to start it the other day and it was hard to start and when it finally did it would not rev up and just continued to back fire , I have checked the reeds and carbs.
    has anybody else had this problem or can help me figure out whats going on.

    thanks


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Ignition system? has it been updated?

  3. #3
    fixer's Avatar
    Join Date
    Feb 2011
    Location
    Mass
    Posts
    498
    +1
    20
    I have had a bad spark plug give similar results, check the firing order too you may have swaped 2 wires. Good place to start.
    Last edited by fixer; 01-17-2012 at 04:39 PM. Reason: spelling

  4. #4
    Thanks for the quick reply guys , how would i know if it has been updated ? the last time i was out on it it started fine but would not rev up and held back that was about a month ago . I replaced the spark plugs when i cam back home and it seemed to rev fine out the water untill the other day

  5. #5
    LaveyT's Avatar
    Join Date
    Jul 2008
    Location
    Cincinnati
    Posts
    672
    +1
    10
    I had a broken reed that would slip in and out of place. it would run fine then start messing up.

  6. #6
    I have checked the reeds and carbs , do you think a coil or stator could cause this ??

  7. #7
    LaveyT's Avatar
    Join Date
    Jul 2008
    Location
    Cincinnati
    Posts
    672
    +1
    10
    If you do a search for ignition update you will get a ton of information on what to look for.

  8. #8
    The 99 SLX already has the updated ignition. Check your battery voltage with a multimeter while cranking it over. The ignition system requires a minimum of 11.6 volts while cranking. If you have less than that, it will still crank normally but it will only fire on 1 or 2 cylinders.

  9. #9
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    The 99 700s and 1050s were not updated. Only the 99 1200 was. Ignition update is possible. What is the part number on your CDI? 4010447 or 4010885 is the updated version.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 X45 Polaris back firing
    By my polaris in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 01-29-2014, 10:33 PM
  2. polaris virage i back fires
    By robin jentzen in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-25-2012, 10:12 PM
  3. 2002 polaris virage txi will not run, just back fires
    By motormadness in forum Polaris Open Discussion
    Replies: 15
    Last Post: 08-16-2010, 07:32 PM
  4. Is Polaris coming back to the ski market.
    By f150vtx in forum Polaris Open Discussion
    Replies: 9
    Last Post: 08-07-2007, 09:11 AM
  5. Back fire ?
    By myth in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 04-25-2006, 08:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •